Once again: ONDOWNLOAD is ignored

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
mguttman
Posts: 31
Joined: Sat Jan 09, 2010 7:32 pm

Re: Once again: ONDOWNLOAD is ignored

Post by mguttman » Tue Mar 30, 2010 12:54 pm

Oh yes! It is my Windows "My Documents" and all the spaces were duly replaced with '<SP>'!

I even tried to use '/' (a forward slash) as a folder separator in lieu of '\', and even '\\', and it is always the same, default dir and file names.
Regards,
Meir
Daniel, Tech Support
Posts: 1483
Joined: Tue Jan 26, 2010 11:35 am

Re: Once again: ONDOWNLOAD is ignored

Post by Daniel, Tech Support » Tue Mar 30, 2010 1:15 pm

Meir, are you actually running this macro directly or from a Perl script? If it is the later, then have you tried running it directly? Sorry for asking so many questions, but I just don't see why its working here and not on your end.
Daniel, iOpus Support
mguttman
Posts: 31
Joined: Sat Jan 09, 2010 7:32 pm

Re: Once again: ONDOWNLOAD is ignored

Post by mguttman » Tue Mar 30, 2010 1:29 pm

Yes Daniel, I am running it directly from Firefox. I always do that first, before ever trying to do it from PERL.

And Daniel, please ask as many questions as you might think off. As a great mentor of mine said: "There are no stupid questions, just stupid answers...!" :wink:
Regards,
Meir
Daniel, Tech Support
Posts: 1483
Joined: Tue Jan 26, 2010 11:35 am

Re: Once again: ONDOWNLOAD is ignored

Post by Daniel, Tech Support » Thu Apr 01, 2010 8:59 pm

Hi Meir,

Could you try using CONTENT=EVENT:SAVETARGETAS for now and we will try to deal with the ONDOWNLOAD bug meanwhile.

Tell me, if it worked/didn't work! :)

Hag Pesach Sameach! :)
Daniel, iOpus Support
mguttman
Posts: 31
Joined: Sat Jan 09, 2010 7:32 pm

Re: Once again: ONDOWNLOAD is ignored

Post by mguttman » Fri Apr 02, 2010 6:33 am

Hag Pesach Sameach to you too!

Don't worry! As I posted here before, as far as my application is concerned, it is solved: I use Perl to analyze, move and rename the downloaded files from their default download folder to their intended place. No problem. I hope this presents you with an opportunity to overcome another hurdle.

Please keep me posted though!
Regards,
Meir
Daniel, Tech Support
Posts: 1483
Joined: Tue Jan 26, 2010 11:35 am

Re: Once again: ONDOWNLOAD is ignored

Post by Daniel, Tech Support » Tue Apr 06, 2010 1:33 pm

Hi Meir, thanks a lot! OK, I will let you know as soon as this is fixed!
Daniel, iOpus Support
Daniel, Tech Support
Posts: 1483
Joined: Tue Jan 26, 2010 11:35 am

Re: Once again: ONDOWNLOAD is ignored

Post by Daniel, Tech Support » Thu Jul 22, 2010 11:52 am

Hi,

I am afraid I forgot to update this thread: the problem was that the macro should still be running when the download dialog appears, otherwise iMacros can not catch it. Often websites need a few seconds for the download to start, so one must make sure the macro is still active then, e. g. by adding a short wait statement at the end. This wait time is not for the download itself, but only for the time the site needs for the download dialog to appear. If the macro continues with other commands, you will not need such a WAIT statement, you need it only when the download is at the end of the macro.

We updated the wiki article here:
http://wiki.imacros.net/ONDOWNLOAD

This is the reason why it did work when there was a URL GOTO=http://www.google.com at the end :)) Sorry for the confusion!

Best regards,
Daniel, iOpus Support
mguttman
Posts: 31
Joined: Sat Jan 09, 2010 7:32 pm

Re: Once again: ONDOWNLOAD is ignored

Post by mguttman » Thu Jul 22, 2010 12:24 pm

Thanks Daniel!

I'll write up a test script shortly!
Regards,
Meir
Daniel, Tech Support
Posts: 1483
Joined: Tue Jan 26, 2010 11:35 am

Re: Once again: ONDOWNLOAD is ignored

Post by Daniel, Tech Support » Thu Jul 22, 2010 12:43 pm

Not at all!! Sorry for forgetting to update this post!
Daniel, iOpus Support
Post Reply