Chrome scripting not work

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Posts: 1
Joined: Wed Feb 08, 2023 12:26 pm

Chrome scripting not work

Post by dtimion » Wed Feb 08, 2023 12:33 pm


I wrote a script that should automate a specific website.

I'm using the latest Chrome version and the latest version of iMacro Enterprise. I installed the Chrome extension.

I run the following script:

Code: Select all

error_log("Start Browser");
        $this->iim1 = new \COM("imacros");
        $feedbackiimOpen = $this->iim1->iimOpen("-cr -runner -crUserDataDir 'C:\Users\Administrator\AppData\Local\Google\Chrome\iMacroUserData'", false, 180);
        error_log("Browser started");
            ->addCode('URL GOTO=?', array(self::CUSTOMER_FIRST_URL))
            ->addCode('TAG POS=1 TYPE=INPUT:TEXT ATTR=ID:username CONTENT=?', array($this->brandUsername))
            ->addCode('TAG POS=1 TYPE=INPUT:PASSWORD ATTR=ID:password CONTENT=?', array($this->brandPassword))
            ->addCode('TAG POS=1 TYPE=A ATTR=ID:signOnButton')
            ->addCode('WAIT SECONDS=10');

Unfortunately, my PHP script gets stuck at iimOpen(). The browser opens, but nothing else happens and of course my PHP script doesn't continue to run for that long.
My php error log shows me only the message "Start Browser" so i can see that it stucks at the iimOpen() command.

Can someone help me with this problem? I have already tried a complete new installation of Chrome and iMacros in vain.
Post Reply