Chrome iMacros Bookmarks request

Discussions and Tech Support related to the iMacros Google Chrome extension.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.
Post Reply
raztus
Posts: 2
Joined: Mon Jun 28, 2010 7:34 pm

Chrome iMacros Bookmarks request

Post by raztus » Mon Jun 28, 2010 7:38 pm

* Please note that the current iMacros V2.0 can read and run iMacros from bookmarks. but it can not store macros in bookmarks. Please use V1.1.1 for creating iMacros inside bookmarks. Please let us know if and how you use the iMacros as bookmarklets feature, and if you want to us to add the "store macro in bookmark" feature to V2.0 again in addition to the new ability to store macros as text files. (From the 2.0 beta release note.)
I use bookmarks as a convenient way to login to some site and automate tasks. Basically, since the frame is not available in chrome, a bookmark is the most convenient (fewest clicks) way to run my iMacros. I just upgraded from v1.1 to fix the multiple instances issue, and really miss this feature!

Also, I added a comment to the google.com extension page for iMacros 2.0 beta:
By default (Windows XP, Chrome 5.0.375.86) the extension does not create its own save directory. This means you cannot save. Instead it throws a silent error: "Error occurred while building file tree: Error: Error calling method on NPObject!". To fix this go to the iMacros Preferences (Tools > Extensions > iMacros > Options) and change the directory for "Macros directory path" to an existing file on the drive. Alternatively, create the directory it wants by default: ...[My Documents]\iMacros\Macros
This seems to be a bug.
Post Reply