Imacros for Chrome on Windows7

Discussions and Tech Support specific to the iMacros for Chrome extension.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
manishasomani
Posts: 1
Joined: Tue Nov 30, 2010 12:33 am

Imacros for Chrome on Windows7

Post by manishasomani » Tue Nov 30, 2010 12:36 am

Somehow i can't Imacros working on windows 7?? somehow the iimInit fails with error code "sTCPInterfaceLoadFailed"

Can somebody please let me know the installer i should be using or are there some special instructions to do the same.

Thanks,
Manisha
Tom, Tech Support
Posts: 3601
Joined: Mon May 31, 2010 4:59 pm

Re: Imacros for Chrome on Windows7

Post by Tom, Tech Support » Wed Dec 01, 2010 12:35 pm

Hi Manisha,

We will be providing a 64-bit version of the TCP interface in the near future.

It is still possible to use the 32-bit version on a 64-bit system if you call the interface from a 32-bit app. For example, if you call a vbs script using the 32-bit version of the Windows Scripting Host (%windir%\SysWOW64\wscript.exe LaunchChrome.vbs) then it works.

http://wiki.imacros.net/x64

LaunchChrome.vbs:

Code: Select all

Dim im, ret
Set im = CreateObject("iMacros")

CheckErr(im.iimInit("-cr"))
CheckErr(im.iimPlay("CODE:URL GOTO=http://www.google.com/" & vbNewLine & "PROMPT Hello!"))

Sub CheckErr(retCode)

	If retCode < 0 Then
		MsgBox im.iimGetLastError(), vbCritical, "Macro Error: " & retCode
		WScript.Quit()
	End If
	
End Sub
Regards,

Tom, iMacros Support
Post Reply