Will iMacros ever really work on Chrome?

Discussions and Tech Support specific to the iMacros for Chrome extension.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Vitae
Posts: 64
Joined: Wed Jan 14, 2009 2:45 am

Will iMacros ever really work on Chrome?

Post by Vitae » Tue Dec 24, 2013 2:18 pm

Can't record macros. I click and nothing happens.
There's this in the console

Code: Select all

Error in event handler for (unknown): TypeError: Cannot read property 'state' of null
    at CSRecorder.onQueryStateCompleted (chrome-extension://cplklnmnlbnpmjogncfgfijoopmnlemp/content_scripts/recorder.js:45:13)
    at extensions::messaging:327:9
    at Function.target.(anonymous function) (extensions::SafeBuiltins:19:14)
    at Event.dispatchToListener (extensions::event_bindings:386:22)
    at Event.dispatch_ (extensions::event_bindings:371:27)
    at Event.dispatch (extensions::event_bindings:392:17)
    at dispatchOnMessage (extensions::messaging:294:22) extensions::event_bindings:375
The State error is referring to this block of code with "data.state"

Code: Select all

CSRecorder.prototype.onQueryStateCompleted = function(data) {
    // force recording after page load
    if (data.state == "recording" && !this.recording) {
        // TODO: remove comment when http://crbug.com/20773 is fixed
        // this.currentFrameNumber = data.frameNumber;
        this.start();
    }
};
Because of this, I have to record in FireFox.
When I do, recorded frames in FireFox don't work in Chrome.
Have a site where I have to access the frame but I can't.
FRAME NAME="dwiframe"
I've tried using the old frames
FRAME F=1 (all the way up to 100 tested)
And nothing works.

Have tried this on 2 Windows XP PC's and a Windows 7 Notebook. All on the current Chrome and iMacros versions.
tomnj
Posts: 1
Joined: Fri Jan 10, 2014 2:26 pm

Re: Will iMacros ever really work on Chrome?

Post by tomnj » Fri Jan 10, 2014 2:31 pm

I'm having lots of problems too.

I install iMacros, record a macro, it runs fine. After a few hours iMacros no longer opens and macros do not run. I uninstall/reinstall and my macros work again... for a few hours... repeat untinstall/reinstall... etc...

My macros are very basic: go to a web page enter in a username/password and click login. That's it.
Post Reply