Autocomplete address field issue

Discussions and Tech Support related to the iMacros Google Chrome extension.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
al_fairy
Posts: 1
Joined: Fri Apr 15, 2016 3:25 am

Autocomplete address field issue

Post by al_fairy » Fri Apr 15, 2016 3:49 am

Hi there,

I am new to iMacros and just started using it yesterday to automate a task for our sales department filling forms on one of our partners website rather than copy and paste.
My issue is there is an address field which is autocomplete (via ajax call). the user has to select a valid address from the returning list to populate other fields such as unit number, house number, street name, ect...

I used this to populate the autocomplete field

TAG POS=1 TYPE=INPUT:TEXT FORM=ID:Form1 ATTR=ID:uctlAddrPhNos_uctlAddress_txtAddress CONTENT=50<SP>Oxford<SP>St<SP>EPPING<SP>NSW<SP>2121
WAIT SECONDS=10

this is the html of the address field
<input name="uctlAddrPhNos$uctlAddress$txtAddress" type="text" id="uctlAddrPhNos_uctlAddress_txtAddress" title="Address" class="RequiredTextBox ui-autocomplete-input" onfocus="IntializeAutoComplete(this, 'DtSearchAddressLinePredictive')" style="width:98%;" autocomplete="off">

so far I could not manage to fill the field with the value. I read the wiki of the macro but I couldn't see any command that can help me with my problem. there is also no error generated. it is just the field always blank.

any help would be great. Looking forward to hearing your thoughts.

Cheers,
Chris
chivracq
Posts: 8929
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Autocomplete address field issue

Post by chivracq » Fri Apr 15, 2016 4:40 pm

al_fairy wrote:Hi there,

I am new to iMacros and just started using it yesterday to automate a task for our sales department filling forms on one of our partners website rather than copy and paste.
My issue is there is an address field which is autocomplete (via ajax call). the user has to select a valid address from the returning list to populate other fields such as unit number, house number, street name, ect...

I used this to populate the autocomplete field

Code: Select all

TAG POS=1 TYPE=INPUT:TEXT FORM=ID:Form1 ATTR=ID:uctlAddrPhNos_uctlAddress_txtAddress CONTENT=50<SP>Oxford<SP>St<SP>EPPING<SP>NSW<SP>2121
WAIT SECONDS=10
this is the html of the address field

Code: Select all

<input name="uctlAddrPhNos$uctlAddress$txtAddress" type="text" id="uctlAddrPhNos_uctlAddress_txtAddress" title="Address" class="RequiredTextBox ui-autocomplete-input" onfocus="IntializeAutoComplete(this, 'DtSearchAddressLinePredictive')" style="width:98%;" autocomplete="off">
so far I could not manage to fill the field with the value. I read the wiki of the macro but I couldn't see any command that can help me with my problem. there is also no error generated. it is just the field always blank.

any help would be great. Looking forward to hearing your thoughts.

Cheers,
Chris
CIM...! :mrgreen: (Always mention your FCI when you open a Thread, read my Sig...)

You are posting in the iMacros for CR Sub-Forum so you are probably on CR..., I would say, try using the EVENT Mode on FF which usually works better with Ajaxy Pages...
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
Post Reply