migrating from iM Browser to Chrome?

Discussions and Tech Support related to the iMacros Google Chrome extension.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
macrophage
Posts: 3
Joined: Sat May 28, 2016 3:49 am

migrating from iM Browser to Chrome?

Post by macrophage » Mon May 30, 2016 2:00 pm

...
UPDATE: 2016-05-20 18:45
The iMacros popup weird behavior described below has now ceased...
Popup can be sized in all directions and positioned as needed, it no longer seeks the top-left corner!?
no changes were made to settings nor installation, only practicing with macros demo examples!

UPDATE: 2016-05-20 20:15 SUCCESS HERE BUT why are the 2 implementations DIFFERENT!?
Issue RESOLVED: ran 2 versions of this macro,
- POS=1 works on both Chrome and iM
TAG POS=1 TYPE=INPUT:SUBMIT ATTR=NAME:this_button

- POS=R1 version fails on the Chrome Test,
TAG POS=R1 TYPE=INPUT:SUBMIT ATTR=NAME:this_button
R1 was used to guarantee that if another submit button was added to the page
as had happened in past workings, it would find the 2nd one

ORIGINAL POST:
FAIL is the word, wish I could brag SUCCESS!

------------------------------------------------------------
Microsoft Windows 7 Professional
Microsoft Windows NT 6.1.7601 Service Pack 1
64-bit Operating System
Installed UI Culture: English (United States)
CLR version 4.0.30319.42000
Internet Explorer version 11.0.9600.18314
Enhanced Protected Mode = False, 64-bit processes for EPM = False
iMacros Browser (x86) version 11.1.495.5175

------------------------------------------------------------
Auxiliary Libraries:
iMacros Direct Screen (iimds) 10.1.0.17
iimir (iimir) 6, 3, 0, 1
iMacros Image Recognition (iimIRm) 2.0.1.33
iMacros Dialog Manager (imsys) 10.0.1.0

------------------------------------------------------------
Scripting Interface Libraries:
iMacros IE Scripting Connector (iimConnector) 10.2.0.124
iMacros FX Connector (iimFirefoxConnector) 2.0.1.12
iMacros Scripting Interface (iimInterface) 10.2.0.124
iMacros FX&Cr Scripting (imtcp) 2.1.0.34

------------------------------------------------------------
User Settings:
EncryptionPasswordMode = No
FolderLogs = Default and working fine
UseExtEditor = True
FolderDownloads = Default and working fine
NewWindowBehavior = Tabs
PlaybackSpeed = Fast
TimeoutPage = 60
FolderDataSources = Default and working fine
FolderMacros = Default and working fine
ExtEditor = notepad2.exe
AFSaveCredentials = False
InstalledSamples = True
AFUser = [/list]
------------------------------------------------------------
Chrome Version 50.0.2661.102 m
- downloaded the extensions
- installed in Chrome - iMacros for Chrome 8.3.5
- set access to files URL
- downloaded and installed File Access - iMacrosSetup_11.1.495.5175_x64.exe
Now the macros folders are visible in Chrome

------------------------------------------------------------

Attempting to migrate to Chrome to have javascript power

As posted on: http://forum.imacros.net/viewtopic.php?f=8&t=26279&e=0
macros are written and functioning in the iM Broswer Client, only need to finish
vbscript Script(s) to tie it all together and have macros loop/chaining power

Problems going to Chrome
It looks as though I will abandon this Chrome migration
and continue with my evaluation on the iM Browser Client

If anything this list may help someone else who is going thru a Chrome install.
I actually do not expect much help as I see posts are disregarded and much bickering
prevails rather than answering questions directly and simply asking if any info is needed.

Some of the problems I was able to resolve as I was typing this list thus I provided the solution
so that one who is new to this and will fall in the many pot holes, will have an entry to verify!
  • First sign of a problem...
    Beta version DO NOT expect it to work a well as the FF and iM/IE versions
    Chrome security will restrict writing to files system even more in near future version
    ...basically be prepared to have to recode...[not a good proposition]
  • The iMacros POPUP which looks similar to the iM Browser Client version behaves uncontrollably!
  • - It can only be sized left or right
  • - When attempting to size it and place it on screen for convenient operation, It resizes itself to the height
    of Chrome window it was clicked from and it slides back to top-left... ??!
    - BUT I was able to do a side by side as long as the iMacros POPUP is on the left side
    if not, they will overlap one disappearing behind the other... I cannot see that is desired nor by design
The worst part is that it narrows the working panel at top of window to a pigeon-hole of a few lines WHILE IT WASTES more than 1/2 the screen with a few buttons(Play, Record, Manage, etc...) and a logo... horrible!!!
  • - if go to settings, NO back button(even in the right-click context menu)... and iMacros POPUP is either
    behind this POPUP or behind the main window, or whateva! annoying, one has to constantly chase
    the iMacros POPUP while working with it...
    --- FOUND NO SOLUTION
  • - Folder hierarchy shows in the side panel, but right-click context menu is missing functionality...
    was not able to do anything until I went to settings and setting the paths!
    ...confusing... if you cannot use the files then why show them in the first place and fool me into thinking it's all good!
    NO ERRORs or warning messages to help figure this out!
    --- solution below
  • - RECORD MACRO - STOP - - SAVE AS PAGE...
    have no idea where it saves a macro upon STOP!? in iM version a #current.iim appears in the side panel macros list
    in chrome... you get NOTHING... no error, no warning, no blink NOTHING!
    --- solution
    well after setting the paths no the various Macros, Downloads, source etc... all of that started to work
    as on the Client IM Browser version!
Note: #Current.iim IS NOT current...
it should say NEW - if you kick-in RECORD, it will overwrite the previous macro as it does in the iM Client version!

- First TEST, I run a macro which runs well in the iM Client
it crashes on various VARIABLES that are not implemented in Chrome
I comment out the lines that stop the process and finally get to the lines that do work!

... and it fails on a simple TAG click!
TAG POS=1 TYPE=INPUT:SUBMIT ATTR=NAME:this_button

- I verified the source, same as before... should find it!
- I ran the macro in the iM Browser version...
all good, hummed right thru!?
any clue? anyone?

...thank you, no, thankkk youooo!
Post Reply