Restart loop after error?

Discussions and Tech Support related to the iMacros Google Chrome extension.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Fire
Posts: 1
Joined: Sun Jun 26, 2016 8:27 am

Restart loop after error?

Post by Fire » Sun Jun 26, 2016 9:05 am

Hey hey...

I've got a very simple imacros script which just loads a page and then clicks a button.... I want this to have on loop over night but when I wake up, the script has stopped because of this error:

Code: Select all

RuntimeError: Navigation error occured while loading url , details: net::ERR_CONNECTION_FAILED, line: 2
This is so annoying...

Is there a possibility, that the loop automatically restarts when there is an error? SO that it don't stop ?


Hope you understand my problem :)
chivracq
Posts: 8921
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Restart loop after error?

Post by chivracq » Sun Jun 26, 2016 12:11 pm

Fire wrote:Hey hey...

I've got a very simple imacros script which just loads a page and then clicks a button.... I want this to have on loop over night but when I wake up, the script has stopped because of this error:

Code: Select all

RuntimeError: Navigation error occured while loading url , details: net::ERR_CONNECTION_FAILED, line: 2
This is so annoying...

Is there a possibility, that the loop automatically restarts when there is an error? SO that it don't stop ?

Hope you understand my problem :)
CIM...! :mrgreen: (Always mention your FCI when you open a Thread, read my Sig, many Commands are not implemented for all Browsers/Versions.)

FCI not mentioned but you are posting in the 'iMacros for CR' Sub-Forum even if your Pb doesn't look very specific to CR to me, so I guess you're using iMacros for CR, in that case, the only possibility for you would be to use '!ERRORIGNORE' which will ignore the RuntimeError and keep your Macro looping.

Funny/strange to see a Spelling Mistake ("occured") in the RuntimeError, hum and an extra Space... Did you Copy&Paste it from the Side Panel or did you retype it...?
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
Post Reply