!ERRORIGNORE not ignoring navigation error on 3rd party site

Discussions and Tech Support related to the iMacros Google Chrome extension.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
andym0908
Posts: 1
Joined: Wed Nov 09, 2016 5:20 pm

!ERRORIGNORE not ignoring navigation error on 3rd party site

Post by andym0908 » Wed Nov 09, 2016 5:41 pm

I'm using iMacros quite successfully, to automate bookings on a site. However, recently this 3rd party site has developed some URL errors, which whilst doesn't cause problems to their site, it is screwing up our automation.

I'm getting this runtime error.

RuntimeError: Navigation error occured while loading url https://.fls.doubleclick.net/activityi;src=;type=;cat=;ord=1478710455328?, details: net::ERR_NAME_NOT_RESOLVED, line: 3

To me, the URL is malformed, but it's not my site so I can't change anything. So, I added:

Code: Select all

SET !ERRORIGNORE YES
But it doesn't seem to work. iMacros still stops when it encounters this error. I'm running iMacros in Chrome, and it's being executed from script (C#).

Any ideas on how I can get the thing to continue to play??
Post Reply