Can Not Run JavaScript In Chrome Imacro

Discussions and Tech Support related to the iMacros Google Chrome extension.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
vtut
Posts: 1
Joined: Wed Jan 18, 2017 5:52 am

Can Not Run JavaScript In Chrome Imacro

Post by vtut » Wed Jan 18, 2017 6:01 am

Can Not Run JavaScript In Chrome Imacro Need Help

// iimPlay("CODE:URL GOTO=http://www.clixsense.com/en/ClixGrid");

var count=1, x=200, y=270, xcount=1;

// Script downloaded from http://imacrosbots.weebly.com
// Visit the site for more scripts and detailed information on editing this script


do {

xpos= x/20;
xpos= xpos-10;
xpos++;

ypos= y+10;
ypos= ypos/20;
ypos= ypos-13;

iimDisplay("X:"+xpos+" Y:"+ypos+"\nCLICKED: "+count+"\nXPos:"+x+" YPos:"+y);

kod = "CODE:TAG POS=1 TYPE=TD ATTR=Y:"+ypos+"&&X:"+xpos+" EXTRACT=TITLE";
// alert(kod);
iimPlay(kod);
title=iimGetLastExtract();
//alert(title);
if (title !== "You have already clicked this position today")
{
y1=y+20;
x1=x;

// x1=x+300;
iimPlay("CODE:WAIT SECONDS=4");
iimPlay("CODE:CLICK X="+x1+" Y="+y1);

// kod = "CODE:TAG POS=1 TYPE=IMG ATTR=SRC:http://csstatic.com/img/tick48.png";

do {
iimPlay("SET !TIMEOUT_STEP 0.1");
iimPlay("SET !TIMEOUT_PAGE 0.1");
iimDisplay("Awaiting validation...");
iimPlay("CODE: TAG POS=1 TYPE=DIV ATTR=TXT:You* EXTRACT=TXT");
test=iimGetLastExtract();
}
while (test == "#EANF#");
// alert(test);

// iimPlay("CODE:WAIT SECONDS=7");



iimPlay("CODE:ONDIALOG POS=1 BUTTON=OK CONTENT=");
iimPlay("CODE:TAB CLOSE");

iimDisplay("X:"+xpos+" Y:"+ypos+"\nCLICKED: "+count+"\nXPos:"+x1+" YPos:"+y1);

}
xcount++;
if (xcount>30)
{
xcount = 1;
y=y+20;
x=180;
}
x=x+20;
count++;

} while(count<61)


Running This Script In Mozilla Successfully But Not In Chrome...........
chivracq
Posts: 8874
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Can Not Run JavaScript In Chrome Imacro

Post by chivracq » Wed Jan 18, 2017 4:19 pm

vtut wrote:Can Not Run JavaScript In Chrome Imacro Need Help

Code: Select all

// iimPlay("CODE:URL GOTO=http://www.clixsense.com/en/ClixGrid");

var count=1, x=200, y=270, xcount=1;

// Script downloaded from http://imacrosbots.weebly.com
// Visit the site for more scripts and detailed information on editing this script


do {

 xpos= x/20;
 xpos= xpos-10;
 xpos++;
 
 ypos= y+10;
 ypos= ypos/20;
 ypos= ypos-13;

 iimDisplay("X:"+xpos+" Y:"+ypos+"\nCLICKED: "+count+"\nXPos:"+x+" YPos:"+y);

 kod = "CODE:TAG POS=1 TYPE=TD ATTR=Y:"+ypos+"&&X:"+xpos+" EXTRACT=TITLE";
// alert(kod);
 iimPlay(kod);
 title=iimGetLastExtract();
//alert(title);
 if (title !== "You have already clicked this position today")
 {
  y1=y+20;
  x1=x;

//  x1=x+300;
  iimPlay("CODE:WAIT SECONDS=4");
  iimPlay("CODE:CLICK X="+x1+" Y="+y1);
  
//  kod = "CODE:TAG POS=1 TYPE=IMG ATTR=SRC:http://csstatic.com/img/tick48.png";
  
  do {
  iimPlay("SET !TIMEOUT_STEP 0.1");
  iimPlay("SET !TIMEOUT_PAGE 0.1");
  iimDisplay("Awaiting validation...");
  iimPlay("CODE: TAG POS=1 TYPE=DIV ATTR=TXT:You* EXTRACT=TXT");
  test=iimGetLastExtract();
  }
  while (test == "#EANF#");
// alert(test);
  
//  iimPlay("CODE:WAIT SECONDS=7");        
  
  
  
  iimPlay("CODE:ONDIALOG POS=1 BUTTON=OK CONTENT="); 
  iimPlay("CODE:TAB CLOSE");

  iimDisplay("X:"+xpos+" Y:"+ypos+"\nCLICKED: "+count+"\nXPos:"+x1+" YPos:"+y1);
  
 } 
 xcount++;
 if (xcount>30) 
 {
  xcount = 1;
  y=y+20;
  x=180;
 }
 x=x+20;
 count++;

} while(count<61)
Running This Script In Mozilla Successfully But Not In Chrome...........
FCIM...! :mrgreen:
=> iMacros for CR v8.4.4....?, CR54...?, OS...?

Yep, normal...!, only FF can run iMacros '.js' Scripts: Javascript Scripting Interface
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
Post Reply