Downloading Tables

Discussions and Tech Support related to the iMacros Google Chrome extension.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
ifchor
Posts: 18
Joined: Wed Oct 03, 2018 2:17 pm

Downloading Tables

Post by ifchor » Mon Nov 05, 2018 1:56 pm

VERSION BUILD=1005 RECORDER=CR
Windows 10 PRO
Google Chrome is up to date
Version 70.0.3538.77 (Official Build) (64-bit)


Hi, I may need your help guys please!
I have been trying to download some tables in a webpage. For that reason, I have been using this code:

SET! EXTRAT_TEST_POPUP NO
TAG POS=1 TYPE=TABLE ATTR=ID:CompGrid1 EXTRACT=TXT
SAVE AS TYPE=EXTRACT FOLDER=* FILE=XXXX

And It has been working fine with the other version so far. It was downloading the table in a CSV file, placing every value in a cell of excel.

Now, I am trying to use it with a new version and the file provides all the table in one cell... and cannot separate the values easily.

Any tips on this? Am I doing something wrong?

I would really appreciate your help. Thank you in advance and Best Regards!

Laura.
chivracq
Posts: 8620
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Downloading Tables

Post by chivracq » Mon Nov 05, 2018 3:42 pm

ifchor wrote:

Code: Select all

VERSION BUILD=1005 RECORDER=CR
Windows 10 PRO
Google Chrome is up to date
Version 70.0.3538.77 (Official Build) (64-bit)
Hi, I may need your help guys please!
I have been trying to download some tables in a webpage. For that reason, I have been using this code:

Code: Select all

SET! EXTRAT_TEST_POPUP NO
TAG POS=1 TYPE=TABLE ATTR=ID:CompGrid1 EXTRACT=TXT
SAVE AS TYPE=EXTRACT FOLDER=* FILE=XXXX
And It has been working fine with the other version so far. It was downloading the table in a CSV file, placing every value in a cell of excel.

Now, I am trying to use it with a new version and the file provides all the table in one cell... and cannot separate the values easily.

Any tips on this? Am I doing something wrong?

I would really appreciate your help. Thank you in advance and Best Regards!

Laura.
Perfect for mentioning your FCI, but include as well that you are using the 'PE' Version... (or you wouldn't be able to use the 'SAVEAS' Command which is not supported in the 'Free' Version...).

OS Language not mentioned, and Excel Version + Language not mentioned either, and your "It has been working fine with the other version" is a bit vague if you don't mention what "other version" means exactly, but if your OS and Excel are not in English, it is possible that they "expect" as '.CSV' Separator not a Comma (',') but probably a Semi-Colon (';') while iMacros by Default uses the Comma as Separator, Option that you can set in Excel for opening '.CSV' Files...
Hum..., and good News looks like it...!, it looks like v10.0.5 for CR now supports the '!DATASOURCE_DELIMITER' Command, meaning you could set that Option directly from iMacros and from your Script before saving the '.CSV' and you then don't need to modify any Settings in Excel... :idea:

The 3 Line Script you've posted contains many Typos btw, 3 Typos in the 1st Line, and 1 Typo in the 3rd Line... :shock:
But without correcting your Typos, that would give stg like:

Code: Select all

SET! EXTRAT_TEST_POPUP NO // => 3 Typos...!
TAG POS=1 TYPE=TABLE ATTR=ID:CompGrid1 EXTRACT=TXT
SET !DATASOURCE_DELIMITER ;
SAVE AS TYPE=EXTRACT FOLDER=* FILE=XXXX // => 1 Typo...!
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
Post Reply