URL GOTO=javascript:... not work after Chrome update to 71 version.

Discussions and Tech Support related to the iMacros Google Chrome extension.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
ZhenKZ
Posts: 7
Joined: Wed Dec 19, 2018 3:05 am

URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by ZhenKZ » Wed Dec 19, 2018 3:16 am

Hello. Some days ago Google Chrome update to 71 version on both my computers. And all my scripts which used URL GOTO=javascript:... stopped working on both computers too! URL GOTO=javascript:... not executed, just skipped!
chivracq
Posts: 8771
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by chivracq » Wed Dec 19, 2018 3:25 am

ZhenKZ wrote:
Wed Dec 19, 2018 3:16 am
Hello. Some days ago Google Chrome update to 71 version on both my computers. And all my scripts which used URL GOTO=javascript:... stopped working on both computers too! URL GOTO=javascript:... not executed, just skipped!
Pff, your Post is a bit vague, read the Forum Rules for posting "a bit correctly"... :idea:
=> FCIM...! :mrgreen: (Read my Sig...)

And post a Script to reproduce your Pb...
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
ZhenKZ
Posts: 7
Joined: Wed Dec 19, 2018 3:05 am

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by ZhenKZ » Wed Dec 19, 2018 5:06 am

For example URL GOTO=javascript:alert("TEST") not work in Chrome 71.
chivracq
Posts: 8771
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by chivracq » Wed Dec 19, 2018 5:17 am

ZhenKZ wrote:
Wed Dec 19, 2018 5:06 am
For example URL GOTO=javascript:alert("TEST") not work in Chrome 71.
Yeah, but "FCIM" again, is it so complicated to count until 3...? :roll:
=> What Version of iMacros are you using...? => v10.0.5...?, + 'Free'/'PE'...?, + OS...? :roll:

Yeah, 'URL GOTO=javascript:alert()' has always been Buggy, ah-ah...! Never worked in FF for example... => Bad Example...!

Easy Workaround: Use 'PROMPT'...! :idea:
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
ZhenKZ
Posts: 7
Joined: Wed Dec 19, 2018 3:05 am

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by ZhenKZ » Wed Dec 19, 2018 6:47 am

v10.0.5
PE
WIN 10
Chrome 71

URL GOTO=javascript:alert() - this is for example. This example works in chrome 70 and older.
In Chrome 71 all lines contain "URL GOTO=javascript" not executed, just skipped.
Check another example for work - URL GOTO=javascript:window.scrollBy(0,20000)
chivracq
Posts: 8771
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by chivracq » Wed Dec 19, 2018 7:04 am

ZhenKZ wrote:
Wed Dec 19, 2018 6:47 am

Code: Select all

v10.0.5 PE
WIN 10
Chrome 71

Code: Select all

URL GOTO=javascript:alert()
- this is for example. This example works in chrome 70 and older.
In Chrome 71 all lines contain "URL GOTO=javascript" not executed, just skipped.
Check another example for work -

Code: Select all

URL GOTO=javascript:window.scrollBy(0,20000)
Oh, good...!, FCI finally mentioned... :D

Well, the 'alert()' is a "bad Example" as it has always been buggy, you were "lucky" if it was working with iMacros for CR in CR70(-), it has never worked in iMacros for FF (at least until v8.9.7, I never used/tried again in any later Versions...).

But hum, the 'scrollBy()' should indeed work, especially if it was working before with the same v10.0.5 Version, in CR70. I'm "alerting" TechSup to have a look...

Some Workaround could be to use the 'EVENT' Mode + the Spacebar... :idea:
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
Tom, Tech Support
Posts: 3529
Joined: Mon May 31, 2010 4:59 pm

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by Tom, Tech Support » Tue Jan 08, 2019 11:07 am

Hi ZhenKZ,

Thank you for reporting this issue here, I have logged the information for further investigation by the development team. It could be that Google has decided to restrict this functionality going forward. I tested the same using the latest iMacros for Firefox and it still works, so that may be an option for you in the meantime.
Regards,

Tom, iMacros Support
chivracq
Posts: 8771
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by chivracq » Tue Jan 08, 2019 1:36 pm

Tom, Tech Support wrote:
Tue Jan 08, 2019 11:07 am
Hi ZhenKZ,

Thank you for reporting this issue here, I have logged the information for further investigation by the development team. It could be that Google has decided to restrict this functionality going forward. I tested the same using the latest iMacros for Firefox and it still works, so that may be an option for you in the meantime.
Hum, not completely clear to me if you managed to reproduce the Pb, (=> "Working in CR70" + "Not working in CR71")... :?

And I've been "bashing" Users when they use "last"/"latest" which is always a bit vague and won't mean anything anymore to sbd reading the Thread a few weeks/months/years later, but @TechSup does it as well, ah-ah...! :P
=> "latest iMacros for Firefox" = "iMacros for FF v10.0.2 ('Free'/'PE') + FF63(?)" I reckon... :wink:

But yep, I can confirm also this Syntax (with 'scrollBy()' only, 'alert()' has never worked on FF afaik) was working at the end of the Beta-Testing Phase with v10.0.2 ('PE') for FF, on FF61 or FF62 at that time (July 2018), the FF Version could also be important (=> FF63 I think "now"...? (Jan 2019)), as for CR it is apparently the Browser Version which is breaking that Functionality/Syntax, and FF with nearly every Version since a few years tends to stupidly blindly copy whatever Chrome has implemented/limited in its previous CR Version...

(The Workaround though I mentioned in my previous Post about the 'EVENT' Mode for a 'scrollBy()' wouldn't work in v10.0.2 for FF which doesn't support (anymore/yet(?)) the 'EVENT' Mode... But I had suggested this Workaround for CR and @OP didn't really follow up anymore... :| )
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
Tom, Tech Support
Posts: 3529
Joined: Mon May 31, 2010 4:59 pm

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by Tom, Tech Support » Tue Jan 08, 2019 2:58 pm

chivracq wrote:
Tue Jan 08, 2019 1:36 pm
Hum, not completely clear to me if you managed to reproduce the Pb, (=> "Working in CR70" + "Not working in CR71")... :?
Yep, I don't log anything for dev unless we have confirmed the issue first.
Regards,

Tom, iMacros Support
Tom, Tech Support
Posts: 3529
Joined: Mon May 31, 2010 4:59 pm

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by Tom, Tech Support » Thu Jan 10, 2019 2:06 pm

Quick update on this issue... the cause of the problem has been identified and a fix is being prepared. No word on a definitive release date, but it could come some time next week.
Last edited by Tom, Tech Support on Fri Jan 11, 2019 10:38 am, edited 1 time in total.
Reason: Revised time frame
Regards,

Tom, iMacros Support
ZhenKZ
Posts: 7
Joined: Wed Dec 19, 2018 3:05 am

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by ZhenKZ » Thu Jan 17, 2019 6:34 am

ОК, thank. I'll wait.
ZhenKZ
Posts: 7
Joined: Wed Dec 19, 2018 3:05 am

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by ZhenKZ » Fri Feb 08, 2019 5:26 am

Still not work!
runawaymacros
Posts: 6
Joined: Wed Feb 07, 2018 3:47 am

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by runawaymacros » Fri Feb 08, 2019 3:54 pm

Is there any work around for this? I rely on this code to create a whole bunch of events but if it's not working then I am really out of luck. Here's my code:
URL GOTO=javascript:void(tinyMCE.activeEditor.setContent('content'));
FCIM:
  • ChromeVersion 72.0.3626.81 (Official Build) (64-bit)
  • Windows 10
  • iMacros Free (Chrome Plugin) v. 10.0.5
This worked for me for the last year without a hitch but has stopped working recently. I saw some comments from people about using the "EVENT" tag but I can't find any documentation or help on how to use that.

Thanks!
Tom, Tech Support
Posts: 3529
Joined: Mon May 31, 2010 4:59 pm

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by Tom, Tech Support » Tue Feb 19, 2019 11:56 am

Quick update on this issue... the issue has been fixed but unfortunately the release has been delayed due to Chrome 71 breaking iMacros upload functionality. The dev team needs more time to investigate a fix for the upload issue so that we can hopefully include both fixes in the next release.
Regards,

Tom, iMacros Support
Tom, Tech Support
Posts: 3529
Joined: Mon May 31, 2010 4:59 pm

Re: URL GOTO=javascript:... not work after Chrome update to 71 version.

Post by Tom, Tech Support » Tue Mar 12, 2019 8:45 pm

Hi everyone,

Another update on this issue... the ancillary issue (broken file upload) that was holding up the release of the fix is no longer an issue, however, some more time is needed to investigate a couple of regression issues that were recently uncovered. So hopefully we will have the release ready by the end of this month or beginning of April.
Regards,

Tom, iMacros Support
Post Reply