macro to fill in password does not trigger javascript validation

Discussions and Tech Support specific to the iMacros for Chrome extension.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Posts: 1
Joined: Mon Jun 22, 2020 6:22 pm

macro to fill in password does not trigger javascript validation

Post by ntingle » Mon Jun 22, 2020 6:31 pm

I'm automating a password update form. When I type in the password manually it triggers javascript that validates the password, and this enables the "proceed" button used to actually perform the update.

However when I run the resulting imacro I recorded to do this, it correctly enters the passwords into the form (I can see the ****** appear in the boxes) however it does not appear to trigger the javascript validation, and so the "proceed" button does not work.

What can I try? The password input elements look like this:

TAG POS=1 TYPE=INPUT:PASSWORD FORM=ID:change-password-form ATTR=ID:NewPassword CONTENT=the-new-password
TAG POS=1 TYPE=INPUT:PASSWORD FORM=ID:change-password-form ATTR=ID:ConfirmNewPassword CONTENT=the-new-password

This has worked in the past, but something has changed on the site.

Free imacros version 1005, latest chrome for windows (83.0.4103.106).
Post Reply