Log:iMacros lost the connection with the scripting interface

Discussions and Tech Support related to using the iMacros Component for .NET in your applications.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Aash
Posts: 1
Joined: Tue Jan 21, 2014 1:04 pm

Log:iMacros lost the connection with the scripting interface

Post by Aash » Thu Jan 30, 2014 9:42 am

Hi,

I'm working with a vb.net application that uses iMacros via .Net scripting interface and is scheduled in Windows scheduler.This application is multithreaded and all the threads basically tries to login to a web portal with username and password fetched from an external config file.if the login attempt fails due to invalidity of the credentials or any network error , imacro takes screenshot of the page and proceeds to other operations.

During some runs i noticed that no screenshots were taken for some of the failure case. On checking the imacros.log file, i came across an error recorded during this scenario as:

"iMacros lost the connection with the scripting interface.The host application seems to have been aborted."

There is no manual intervention as it runs as scheduled in windows scheduler.The application is not crashed as evident from other threads which executes fine and finishes the execution as expected.
Can you help finding what this error from the iMacros.log file means exactly and what is causing an issue like this?

Thanks in advance!!!
Aash
chivracq
Posts: 8636
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Log:iMacros lost the connection with the scripting inter

Post by chivracq » Wed Feb 05, 2014 10:44 pm

I don't think any other User will be able to help you, your Question is more for iMacros TechSupport I suspect, but they don't come very often on the Forum...

If using the Scripting Interface, you must have a full License to use with the Commercial Edition I reckon and you better open a Ticket with TechSupport if you want a Response... and post later on the Answer here if you feel like sharing... (I would be interested...)
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
Post Reply