Error -1300 when extracting data

Discussions and Tech Support related to website data extraction, screen scraping and data mining using iMacros.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Patrick_S
Posts: 1
Joined: Tue Dec 05, 2017 8:46 pm

Error -1300 when extracting data

Post by Patrick_S » Tue Dec 05, 2017 8:58 pm

Hello-

I am trying to extract data from a webpage but am getting this error when I try to actually select the table for download.

This is the error that is returned:

Error -1300: Cannot find HTML element using specified Selector expression: #highcharts-f2n5udx-4>svg>g:nth-of-type(7)>path. Line 9: TAG SELECTOR="#highcharts-f2n5udx-4>svg>g:nth-of-type(7)>path"

Not sure what the issue is here. Here is the full script, for reference. I am getting the error on the "TAG SELECTOR" row.

VERSION BUILD=11.5.498.2403
TAB T=1
TAB CLOSEALLOTHERS
SET !PLAYBACKDELAY 0.2
URL GOTO=http://www.bonds.is/market-overview/?ty ... okid=75201
'
TAG POS=1 TYPE=SELECT ATTR=ID:type CONTENT=%Yield
TAG POS=1 TYPE=BUTTON:SUBMIT ATTR=ID:btnDraw
TAG SELECTOR="#highcharts-f2n5udx-4>svg>g:nth-of-type(7)>path"
ONDOWNLOAD FOLDER=d:\intdaily\iceland\bond FILE=Y0414.csv WAIT=YES
TAG POS=1 TYPE=DIV ATTR=TXT:Download<SP>CSV
TAG POS=1 TYPE=SELECT ATTR=ID:type CONTENT=%Price
TAG POS=1 TYPE=BUTTON:SUBMIT ATTR=ID:btnDraw
TAG SELECTOR="#highcharts-f2n5udx-8>svg>g:nth-of-type(7)>rect"
ONDOWNLOAD FOLDER=d:\intdaily\iceland\bond FILE=P0414.csv WAIT=YES
TAG POS=1 TYPE=DIV ATTR=TXT:Download<SP>CSV
chivracq
Posts: 8144
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Error -1300 when extracting data

Post by chivracq » Tue Dec 05, 2017 9:37 pm

Patrick_S wrote:Hello-

I am trying to extract data from a webpage but am getting this error when I try to actually select the table for download.

This is the error that is returned:

Code: Select all

Error -1300: Cannot find HTML element using specified Selector expression: #highcharts-f2n5udx-4>svg>g:nth-of-type(7)>path. Line 9: TAG SELECTOR="#highcharts-f2n5udx-4>svg>g:nth-of-type(7)>path"
Not sure what the issue is here. Here is the full script, for reference. I am getting the error on the "TAG SELECTOR" row.

Code: Select all

VERSION BUILD=11.5.498.2403
TAB T=1
TAB CLOSEALLOTHERS
SET !PLAYBACKDELAY 0.2
URL GOTO=http://www.bonds.is/market-overview/?type=bond&orderbookid=75201
'
TAG POS=1 TYPE=SELECT ATTR=ID:type CONTENT=%Yield
TAG POS=1 TYPE=BUTTON:SUBMIT ATTR=ID:btnDraw
TAG SELECTOR="#highcharts-f2n5udx-4>svg>g:nth-of-type(7)>path"
ONDOWNLOAD FOLDER=d:\intdaily\iceland\bond FILE=Y0414.csv WAIT=YES
TAG POS=1 TYPE=DIV ATTR=TXT:Download<SP>CSV
TAG POS=1 TYPE=SELECT ATTR=ID:type CONTENT=%Price
TAG POS=1 TYPE=BUTTON:SUBMIT ATTR=ID:btnDraw
TAG SELECTOR="#highcharts-f2n5udx-8>svg>g:nth-of-type(7)>rect"
ONDOWNLOAD FOLDER=d:\intdaily\iceland\bond FILE=P0414.csv WAIT=YES
TAG POS=1 TYPE=DIV ATTR=TXT:Download<SP>CSV
=> Using iMB v11.5.

Hum..., I cannot really reproduce your Pb and replay your Script as you are using some Statements with the 'TAG SELECTOR' Mode which is not supported on FF (using the Free Add-on v8.8.2 or v8.9.7) that I use myself, so I don't know what you are doing after clicking on the 'Draw' Button, but the "f2n5udx-4" and "f2n5udx-8" parts in the ID's of their respective HTML Elements that you are trying to click on look Dynamic to me...

Try to re-record your Actions without ID's, or using the "Standard" 'TAG POS' Mode + replacing that changing part with a Wildcard or using other Attribute(s) than the ID, maybe combined with Relative Positioning, or using the 'EVENT' Mode without ID's. :idea:
I've never used this 'TAG SELECTOR' Mode, so I don't know if it supports Wildcard, but you can try as well...
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
Post Reply