Extracts before value shows up on web page

Discussions and Tech Support related to website data extraction, screen scraping and data mining using iMacros.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
sdtony
Posts: 31
Joined: Tue Dec 13, 2005 6:15 am

Extracts before value shows up on web page

Post by sdtony » Tue Jan 03, 2006 12:37 am

I'm using

EXTRACT POS=1 TYPE=TXT ATTR=<FONT<SP>face="Times<SP>New<SP>Roman"<SP>size=3>*

to extract the result from a web page.

The only problem is that sometimes the macro extracts before the web page has time to download everything onto the page (including the desired value) then returns a value of #EANF#. I've tried using WAIT SECONDS=#DOWNLOADCOMPLETE# but then the macro exhausts the whole time out period and never extracts the value.
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Tue Jan 03, 2006 3:46 pm

Please see http://www.iopus.com/iim/help/faq_wait_ ... pleted.htm and http://www.iopus.com/iim/help/faq_test_image.htm for a list of possible solutions. The IMAGESEARCH method is the most reliable method, as it works with any kind of web page.
Post Reply