How to automate Firefox with iimInit ("-fx")

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Tom, Tech Support
Posts: 3491
Joined: Mon May 31, 2010 4:59 pm

Re: How to automate Firefox with iimInit ("-fx")

Post by Tom, Tech Support » Tue Jul 26, 2011 4:25 pm

sanfric wrote:Yes, the script runs the first time I use it, but not twice.
Ah yes, I see now. Sorry for the confusion.
Regards,

Tom, iMacros Support
omnea
Posts: 4
Joined: Tue Nov 19, 2013 2:58 pm

Re: How to automate Firefox with iimInit ("-fx")

Post by omnea » Wed Dec 11, 2013 11:51 am

Hi there,

i have a problem to start imacros with firefox with iimInit("-fx") command.
If i´m starting macro with the default imacros browser it works, excepted the lack of read properly html elements.
I will list below troubleshooting infos from imacros browser and the version of firefox.
since a couple of days play on firefox version: 26.0 won´t work anymore, dont know what the reason is to get permanently the -931 error?
please help me, a solution will have big influence to buy enterprise editon or not!

i am using trial edition:
iMacros Browser Version 9.05.2613
Trial Version
Released on 24 September 2013
and here are my troubleshooting Informations from iMacros Browser:

Microsoft Windows 7 Home Premium
Microsoft Windows NT 6.1.7601 Service Pack 1
64-bit Operating System
Installed UI Culture: German (Germany)
CLR version 4.0.30319.18052
Internet Explorer version 11.0.9600.16428
iMacros Browser version 9.0.5.2613
------------------------------------------------------------
Mozilla Firefox version 26.0 (de)
Profile "default" iMacros addon version 8.6.0
------------------------------------------------------------
Auxiliary Libraries:
iMacros Direct Screen (iimds) 7.5.0.7
iimir (iimir) 6, 3, 0, 1
iMacros Image Recognition (iimIRm) 2.0.0.26
imsys (imsys) 5, 10, 0, 2
iMacros RunAs Agent (iimrunner) 8.2.0.900
iMacros Editor (iMacrosEditor) 9.0.1.62
------------------------------------------------------------
Scripting Interface Libraries:
iMacros IE Scripting Connector (iimConnector) 8.2.0.0
iMacros FX Connector (iimFirefoxConnector) 2.0.0.10
iMacros Scripting Interface (iimInterface) 8.5.0.104
iMacros FX&Cr Scripting (imtcp) 1.0.0.680
iMacros Scripting Interface (iimInterface64) 8.5.0.104
iMacros FX&Cr Scripting (imtcp64) 1.0.0.680
------------------------------------------------------------
User Settings:
Profiler = True
Split = bd
FolderLogs = C:\Users\joe\Documents\iMacros\Logs
FolderDownloads = C:\Users\joe\Documents\iMacros\Downloads
EncryptionPasswordMode = No
NewWindowBehavior = Tabs
InterfaceType =
PlaybackSpeed = Fast
TimeoutPage = 60
FolderDataSources = C:\Users\joe\Documents\iMacros\DataSources
FolderMacros = C:\Users\joe\Documents\iMacros\Macros

iOpus Software GmbH
iMacros Browser Version 9.05.2613
Trial Version
Released on 24 September 2013

and firefox version: 26.0
Post Reply