iimInit with -fx (-931)

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
omnea
Posts: 4
Joined: Tue Nov 19, 2013 2:58 pm

iimInit with -fx (-931)

Post by omnea » Tue Dec 10, 2013 4:38 pm

Hi there,
i have a couple of questions about imacros enterprise in trial mode:

1.)
i am in trial phase with the enterprise editon and therefor i need to start up imacros with firefox.
since yesterday icant invoke imacros with -fx. i get allways the errorcode (-931) cannot access file.
but if im starting imacros with default imacros browser playCode gives sOK back.
sometimes i see also from firefox a messagebox with information that imacros is int trail mode or something like that.
So who can i get it work with in -fx mode?

2.) firefox is the most stabil browser with imacros in my cases.
idont know why but this browser reads better html elements than other browsers like ie or chrome.
and firefox has an adblocker plugin which idont have found for the default imacros browser.
is there anyway to run imacros with default imacros browser with adblocker?
Why cant read ie (default imacros browser) not so exactly the html elements like firefox?
Is there a way to optimize the run over ie browser?

so this question have to be clarified to make a decision for or against imacros to buy.

thank you in advance :)
Tom, Tech Support
Posts: 3526
Joined: Mon May 31, 2010 4:59 pm

Re: iimInit with -fx (-931)

Post by Tom, Tech Support » Thu Dec 12, 2013 5:54 pm

Hi omnea,

1) Do you have the iMacros for Firefox add-on installed in your Firefox? This is also required for launching macros in Firefox using the scripting interface.

2) "is there anyway to run imacros with default imacros browser with adblocker?" => the iMacros browser uses the same plug-ins that are installed into IE, e.g. Flash, Java, Silverlight. However, this may not work for all plug-ins. If you can find an adblocker plug-in for IE then try it, it might work in the iMacros browser too!
Regards,

Tom, iMacros Support
Post Reply