Options=>Paths getting reset to defaults

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
mwhopkins
Posts: 1
Joined: Fri Feb 24, 2012 9:14 pm

Options=>Paths getting reset to defaults

Post by mwhopkins » Wed Oct 22, 2014 8:08 pm

We have some VBScript programs that have been running for quite some time. They run some iMacros scripts to automate some processing. Starting yesterday, when they are fired off from a remote computer using PsExec, they reset the options=>paths back to the default. When they are run from the local machine, the paths do not get changed.

I have verified that there is not some new policy that restricts the registry change - or resets it when the user logs in.

I also verified that iMacros itself is making the registry change.

I can log into that machine, and run the vbs program fine, the paths remain as I want them and stay that way. As soon as a the vbs program is kicked off from a remote computer, the values change to the default.

I even put code in the vbs programs to update the registry with the correct values, but it appears that as soon as iMacros is initiated (iiminit or iimopen) or run in that script, the path is reset to the default.

Anyone have any suggestions as to why this is happening?

iMacros 10.00.2738
Windows 7
Using the iMacros browser

Thanks, Matt
Post Reply