iMacros hanging or freezing during scripting playback

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:


Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

iMacros hanging or freezing during scripting playback

by computerwhizguy on Fri Jan 26, 2007 3:03 pm


I was wondering if anyone else is experiencing hanging or freezing problems during playback of macros using the scripting interface. I have found that most of the time my macros will stop playing and the sidebar where it is usually orange/red/green/yellow will change to white and stay that way. The place where it freezes is different each time. Sometimes it will hang within a couple of seconds, sometimes it will run for more than a minute. This seems to only occur on Windows 2000 desktops. The website that is being visited doesn't seem to matter. I have been able to make the samples that hit the iOpus website hang. Support folks have tried to help, but they are unable to replicate. I am using the latest version 5.21

Posts: 4
Joined: Thu Jan 25, 2007 4:12 pm

by GreboDB on Sun Mar 04, 2007 2:56 pm


I recently upgraded to v 5.22 from 4.2 and am having similar problems with scripts that used to run OK.

I am running the script through VBscript and close and restart Imacros on a regular basis to ensure that memory is released.

As it is running, I see the following applications running on the server :

Task Status
iMacrosBrowser Running
imgr Running

The imgr task seems to come in and out of the task manager list on a regular basis.

After anywhere between 30 second and hours, the script will suddenly stop running (and never at the same point, it has also got to end of job before successfully). Once it hangs I see the following on task manager:

Task Status
iMacrosBrowser Not Responding
iMacrosBrowser Not Responding

Process list only shows one imacro.exe running though and when I end task it, then the script continues and fire off Imacros again and works for a while.

Any ideas how I can determine what is happening? CPU and memory usage is very low when I check task manager during the hang.


Posts: 11
Joined: Wed Feb 21, 2007 8:21 am

by computerwhizguy on Mon Mar 05, 2007 8:27 am


I am glad to hear I am not alone. I am at a loss to explain it. Originally I though that maybe one of the other programs I have installed was conflicting with the app, but since previous version work, I am not sure. My original thought was the real-time antivirus program getting in the way of creating files, because they contain content that resembles a virus, so the iMacros play method gets hung up.

One question I have for you is what OS are you using? I haven't had trouble on XP or Server 2003, only on 2000 Pro.

FWIW, I found that using version v5.1 of IMacros works fine. Something with the update from v5.1 -> v5.2 got broken. This may buy you some of the new features you are looking for over v4.1

The support folks are unable to replicate this problem, they have tried the latest version on 2000 with success in a longer loop.

Posts: 4
Joined: Thu Jan 25, 2007 4:12 pm

by Tech Support on Mon Mar 05, 2007 12:48 pm

Hi Grebo, are you also using Win 2000?

If anybody else is experiencing such an issue, please post it here, too.
User avatar
Tech Support
Posts: 5003
Joined: Tue Sep 20, 2005 12:25 pm

by GreboDB on Mon Mar 05, 2007 1:50 pm

No, I am using SBS2003.

I think it has something to do with either running mutiple scripts at the same time or another process trying to access a file that the macro is using.

If I run a single Macro then I have no issues. If I run two macros then eventually one will hang. The drives the macros are extracting to are a shared drive. If I run a single macro and then from another PC access the shared drive, again the macro seems to hang... Although this may have been coincidence!!!

Where can I get the 5.21 install files from to try this and see if it is better?

I am also having another issue with 5.22. A script that used to run OK on 4.2 is taking a lot longer (i.e 24 Hours compared to 2-3 Hours on 4.2) to extract from pages which hold a table with many (100+) entries. The parsing seems to take longer and longer the further down the table the extract moves. Is this a known issue?


Posts: 11
Joined: Wed Feb 21, 2007 8:21 am

by computerwhizguy on Tue Mar 06, 2007 8:20 am


Take a look at <>. I was suggesting you try version 5.1 not 5.2 (at least for the problem I am experiencing it went away in 5.1). Perhaps we are talking about two problems that look similar.

When you say run two macros, you don't mean concurrently, you mean you create the iMacros object and call iimPlay with two different script names? And you dont have trouble if you only run one script per iMacros object? Or you are running multiple iMacros objects at the same time in different processes. And when you say extracting, you mean you are capturing information from a web site and saving it to a file share on a file server? Best I can tell iMacros is a nice wrapper around IE, and IE doesn't have problems downloading multiple web sites in multiple processes, but they may be writing temp files and such that are in a shared area and may get stepped on by mutiple processes. I would try to use the filemon tool from sysinternals to test this out <> or process monitor <>. It would log this process/file conflict.

I have never had any performance problems like you have described. I have been surprised at how fast it actually work. I have loaded a 2MB web page with 4000 checkboxes and 4000 hidden form fields, going though and checking just a few checkboxes and submitting the form. I all worked in a matter of 75 seconds to load and select them. I could see where a more complex regular expression may be CPU intense. Can you tell if you are CPU bound while this is happening?

Posts: 4
Joined: Thu Jan 25, 2007 4:12 pm

by Beam on Sun Mar 18, 2007 8:06 am

Did you guys manage to find a solution for this. I seem to be experiencing exactly the same problems using v 5.22 and XP pro...
Posts: 2
Joined: Wed Mar 07, 2007 1:40 am

Getting same problem

by frankie5string on Mon Mar 19, 2007 7:46 am

Hi there guys, I just joined today...

I too am experiencing the lockup of my iOpus sessions.

I'm calling iOpus 5.22 from VB6 on Windows 2k using the iimPlay function and when the iOpus script completes its run, it hangs, with the green status changing to white and stopping there. After about 2 or 3 minutes it will come back to life. However, while it's hanging my VB6 manages to read in the last extracted information...

Any ideas?

I'm calling it like this:

Function DoIIM(myid)
Dim iret As Long
Dim iplay As Integer
Dim exdata

'MsgBox theid
'MsgBox myid
Set iim1 = CreateObject("InternetMacros.iim")
iret = iim1.iimInit("-tray", True)
iret = iim1.iimPlay("BC" & myid & "-RegSetup")
exdata = iim1.iimGetLastExtract()
'iret = iim1.iimPlay("BCOnline-ExDocID")
If iret < 0 Then
MsgBox iim1.iimgetlasterror()
End If
MsgBox exdata
iret = iim1.iimExit
'I put the data extraction in another function, but for now testing it in here as above.
'Call ExtractDocid

End Function
Posts: 7
Joined: Mon Mar 19, 2007 7:42 am

Re: iMacros hanging or freezing during scripting playback

by DEiMacrosUser on Mon Jun 09, 2008 9:39 am

Hi there,

I'm using iMacros verion 6.14 and have the same problem.
My script is called via Java. It simulates a number of users performing some action on a Enterprise Portal. I want that all of the user are akting at the same time, but unfortunatly most of the iMacro browser are 'not responding' according to the task manager of MS Windows Server 2003 EP x64 edition.

Has anyone a suggestion what the problem is?

Each of my simulated users is a runnig Thread in the JVM and uses the same Macro-Scripst. Could this the origin of that problem be?!
Posts: 10
Joined: Tue May 06, 2008 2:38 pm

Re: iMacros hanging or freezing during scripting playback

by reiboul on Fri Jul 11, 2008 1:30 am

I'm experiencing similar problems using an up-to-date IMacro Scripting Interface with a Java controller. I'm launching several instances of IMacro, and it seems to crash whenever I do something else as simple as switching windows...

Tested on ~10 PCs, half-XP, half-2000

All systems are up-to-date, using IE6 (Windows XP Pro SP2, Windows 2000 SP4)

Unfortunately I don't have any tips for now :'(
Posts: 10
Joined: Thu Apr 17, 2008 2:25 am

Re: iMacros hanging or freezing during scripting playback

by PSF Developer on Fri Aug 08, 2008 8:22 am

I’m using the lasts iMacros version on a C# application. When a run it debugging locally(Win server 2003 - VS 2005) it runs ok. I’ve installed iMacros on a server(Win Server 2003), import the corresponding iMacro and it frozen when it tries to execute this line:

Status status = iMac.iimPlay("My iMacro", 12000);

If I execute “My iMacro” with iMacro Browser it also runs ok, the problem is from the code… see the log file:

8/7/2008 9:25:36 AM 1880 Running iMacros (*PRO Edition*)
8/7/2008 9:29:39 AM 1880 START Cleared Trades
8/7/2008 9:30:48 AM 1880 ONDOWNLOAD
8/7/2008 9:30:49 AM 1880 STOP, OK
8/7/2008 9:37:46 AM 1880 EXIT
08/08/2008 10:47:38 a.m. 1996 NIS-CMD: PLAY| -macro Cleared[SP]Trades[SP]Ny

My program just never execute that line, no exception throw, and not status return, it just hung up… Do you have any clue of what the problem might be?

PD: I have the pay version now.

Julián Mendiola | PSF Developer Leader
PSF Developer
Posts: 1
Joined: Fri Aug 08, 2008 7:41 am

Re: iMacros hanging or freezing during scripting playback

by OscarS on Mon Dec 01, 2008 10:01 am

I'm having the same problem on a Win2K machine. Error code reports -1 indicating (according to the user manual) that the software isn't installed correctly. Tried uninstalling and reinstalling including deleting all registry entries in local machine software related to the iMacros program with no luck. Program runs for awhile then just stops. No Rhyme or reason for it. Log just ends where the program stops. No clue as to what happened. Macros run fine on XP Notebook Has anyone found a solution to this problem? I'm using ver 6.20 Build 119. The latest, as reported from the iOpus web site. A search of the forums doesn't return any solution to this problem, but does show many users with win2k pro all having the same issue.

Any help appreciated.


Posts: 1
Joined: Tue Aug 26, 2008 4:20 am

Return to Scripting and Command Line Interface

Who is online

Users browsing this forum: No registered users and 5 guests