Error -1300: Cannot find HTML element of type "A:"

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.
Post Reply
popbob
Posts: 1
Joined: Sun Jun 24, 2018 3:55 pm

Error -1300: Cannot find HTML element of type "A:"

Post by popbob » Sun Jun 24, 2018 4:03 pm

Hi,

I have trouble about: Error -1300: Cannot find HTML element of type "A:" with attribute(s) "TXT:Military<SP>History<SP>on<SP>the<SP>Web/Simon<SP>Fowler".. Line 15: TAG POS=1 TYPE=A ATTR=TXT:{{!COL1}}

This my script:

VERSION BUILD=12.0.501.6698
TAB T=1
TAB CLOSEALLOTHERS
' Specify input file (if !COL variables are used, iMacros automatically assumes a CSV format of the input file
SET !DATASOURCE "fix.csv"
'Use the Play(Loop) button to run the macro in a loop
SET !LOOP 2
'Start at line 2 to skip the header in the file
'Increase the current position in the file with each loop
SET !DATASOURCE_LINE {{!LOOP}}
'SET !PLAYBACKDELAY 0.00
URL GOTO=http://ilibdemo.cmcsoft.com:8884/home.a ... r&vr=51762
TAG POS=1 TYPE=SELECT ATTR=NAME:tdContentDLBibManRender_length CONTENT=%500
TAG POS=1 TYPE=DIV ATTR=TXT:Hiển<SP>thị<SP>1050100200300400500<SP>bản<SP>ghi
TAG POS=1 TYPE=A ATTR=TXT:{{!COL1}}
TAG POS=12 TYPE=A ATTR=CLASS:btn<SP>btn-mini
TAG POS=1 TYPE=INPUT:TEXT ATTR=NAME:r23c1text CONTENT={{!COL2}}
TAG POS=65 TYPE=A ATTR=CLASS:btn<SP>btn-mini
TAG POS=2 TYPE=INPUT:TEXT ATTR=NAME:r23c1text CONTENT={{!COL3}}
TAG POS=68 TYPE=A ATTR=CLASS:btn<SP>btn-mini
TAG POS=3 TYPE=INPUT:TEXT ATTR=NAME:r23c1text CONTENT={{!COL4}}
TAG POS=71 TYPE=A ATTR=CLASS:btn<SP>btn-mini
TAG POS=4 TYPE=INPUT:TEXT ATTR=NAME:r23c1text CONTENT={{!COL5}}
TAG POS=74 TYPE=A ATTR=CLASS:btn<SP>btn-mini
TAG POS=5 TYPE=INPUT:TEXT ATTR=NAME:r23c1text CONTENT={{!COL6}}
TAG POS=77 TYPE=A ATTR=CLASS:btn<SP>btn-mini
TAG POS=6 TYPE=INPUT:TEXT ATTR=NAME:r23c1text CONTENT={{!COL7}}
TAG POS=80 TYPE=A ATTR=CLASS:btn<SP>btn-mini
TAG POS=7 TYPE=INPUT:TEXT ATTR=NAME:r23c1text CONTENT={{!COL8}}
TAG POS=83 TYPE=A ATTR=CLASS:btn<SP>btn-mini
TAG POS=1 TYPE=DIV ATTR=CLASS:span10<SP>text-center
TAG POS=8 TYPE=INPUT:TEXT ATTR=NAME:r23c1text CONTENT={{!COL9}}
TAG POS=2 TYPE=A ATTR=TXT:Ghi<SP>lại
TAG POS=1 TYPE=A ATTR=TXT:Quay<SP>lại

If I change to: "TAG POS=1 TYPE=A ATTR=TXT:Military<SP>History<SP>on<SP>the<SP>Web/Simon<SP>Fowler" it can run.
So please help me!
Post Reply