[HELP] vbs script, iMacros Connection timed out

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Posts: 1
Joined: Fri May 04, 2018 7:17 am

[HELP] vbs script, iMacros Connection timed out

Post by AleJuliet » Fri May 04, 2018 7:37 am

iMacros version: 10.0.1
Chrome version: 66.0.3359.139 (64-bit)
Windows 10

This error has been happening for a while (two months or more) and I don't know how to fix it. We have a vbs script that runs every day using the Task Scheduler and it works fine for a couple of days. Suddenly we start having errors, and it's like iMacros doesn't start. Find the errors bellow:

Line 68 TCP interface error: Connection timed out. Is "Allow access to file URLs" enabled in iMacros for Chrome? See http://wiki.imacros.net/iMacros_for_Chr ... ing_Chrome --> this error comes from iimL.iimOpen()
Line 78 Browser was not started. iimOpen() failed? --> this is when tries to run the iMacros file using "iimPlay"
Line 92 Could not open server pipe \\.\pipe\im-cr-default.TestAccount --> this is with "iimClose()"

We have "Allow access to file URLs" enabled since the beginning. However, if we disable this checkbox and check it again on the iMacros extension options, next time the vbs is ran everything works fine. But then again, two days later we have the same error.

I have tried to understand why this happen, but I don't even know how to get more information about the error. We have the latest Chrome and iMacros version, so that can't be it.

Could someone please guide me through this? I really don't know what to do :(

Post Reply