Hyphen (-) Not Recognized in PROXY ADDRESS

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
kkipling5
Posts: 13
Joined: Sat Aug 03, 2019 7:29 am

Hyphen (-) Not Recognized in PROXY ADDRESS

Post by kkipling5 » Fri Oct 04, 2019 12:18 pm

iMacros: 8.9.7
Browser: FIrefox 49
Windows: 10

I'm using the PROXY ADDRESS command and I've noticed that if hyphen is present in the proxy address, iMacros skips that command.

Example:

The following will be executed:

Code: Select all

PROXY ADDRESS=us.dc.smartproxy.com:{{PORT}}
The following will not be executed:

Code: Select all

PROXY ADDRESS=us.dc-smartproxy.com:{{PORT}}
One can check whether the change has or hasn't taken place by going to Netwok tab under Advanced in Options page.

Has anyone been able to replicate the issue? Is there a possible workaround for it?
User avatar
thecoder2012
Posts: 367
Joined: Sat Aug 15, 2015 5:14 pm
Location: Internet
Contact:

Re: Hyphen (-) Not Recognized in PROXY ADDRESS

Post by thecoder2012 » Fri Oct 04, 2019 1:46 pm

kkipling5 wrote:
Fri Oct 04, 2019 12:18 pm
Has anyone been able to replicate the issue?
Bug in my opinion because the iMacros regex has no support for "-" in the proxy command.
Errormessage in IMacros: "BadParameter: expected server name or IP address with port number as parameter 1 (Error code: -911)"
kkipling5 wrote:
Fri Oct 04, 2019 12:18 pm
Is there a possible workaround for it?
Workarounds:
  1. Foxyproxy addon with modification (with URL GOTO and pure iim)
  2. Javascript with Proxycommand (see using proxy list or plugin on firefox?, about the proxy,a big error in wiki, Change sock5 proxy?)
  3. Proxy redirect (e.g. CCProxy Free, Softether) if you have only 1 proxy or external commands (see Use tor with imacros)
Join 9kw.eu Captcha Service now and let your iMacros continue downloads and scripts while you sleep. - Custom iMacros? Contact me! :idea:
chivracq
Posts: 8781
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Hyphen (-) Not Recognized in PROXY ADDRESS

Post by chivracq » Fri Oct 04, 2019 6:35 pm

kkipling5 wrote:
Fri Oct 04, 2019 12:18 pm

Code: Select all

iMacros: 8.9.7
Browser: FIrefox 49
Windows: 10
I'm using the PROXY ADDRESS command and I've noticed that if hyphen is present in the proxy address, iMacros skips that command.

Example:

The following will be executed:

Code: Select all

PROXY ADDRESS=us.dc.smartproxy.com:{{PORT}}
The following will not be executed:

Code: Select all

PROXY ADDRESS=us.dc-smartproxy.com:{{PORT}}
One can check whether the change has or hasn't taken place by going to Netwok tab under Advanced in Options page.

Has anyone been able to replicate the issue? Is there a possible workaround for it?
thecoder2012 wrote:
Fri Oct 04, 2019 1:46 pm
kkipling5 wrote:
Fri Oct 04, 2019 12:18 pm
Has anyone been able to replicate the issue?
Bug in my opinion because the iMacros regex has no support for "-" in the proxy command.
Errormessage in IMacros: "BadParameter: expected server name or IP address with port number as parameter 1 (Error code: -911)"
kkipling5 wrote:
Fri Oct 04, 2019 12:18 pm
Is there a possible workaround for it?
Workarounds:
  1. Foxyproxy addon with modification (with URL GOTO and pure iim)
  2. Javascript with Proxycommand (see using proxy list or plugin on firefox?, about the proxy,a big error in wiki, Change sock5 proxy?)
  3. Proxy redirect (e.g. CCProxy Free, Softether) if you have only 1 proxy or external commands (see Use tor with imacros)

Another Workaround would be to first use some Online 'DNS-Check' Page to extract the corresponding IP-Address to reuse dynamically in the 'PROXY' Command with a Var... :idea:
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
kkipling5
Posts: 13
Joined: Sat Aug 03, 2019 7:29 am

Re: Hyphen (-) Not Recognized in PROXY ADDRESS

Post by kkipling5 » Fri Oct 04, 2019 6:42 pm

zproxy.lum-superproxy.io:22225

That is the actual proxy address and port I need to use. I did the DNS check to figure out IPv4 but it comes up with new IP's each time.
chivracq
Posts: 8781
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Hyphen (-) Not Recognized in PROXY ADDRESS

Post by chivracq » Fri Oct 04, 2019 6:59 pm

kkipling5 wrote:
Fri Oct 04, 2019 6:42 pm
zproxy.lum-superproxy.io:22225

That is the actual proxy address and port I need to use. I did the DNS check to figure out IPv4 but it comes up with new IP's each time.

Yeah well, that "specific" IP then probably remains "valid" for a few Seconds at least, I reckon...
It takes about 0.1 Sec to extract it from the DNS-Page (in a 'TAB_2' maybe), to input it in the 'PROXY' Command, I would think... :P

But OK, was just "an Idea", I don't use Proxies in my Scripts, so I never "really" did any Digging/Testing about it..., @thecoder2012 is much more knowledgeable about that Func than me... :oops:

And otherwise, @OP, I think you are Advanced enough to modify yourself the '.xpi' to prevent the '-' to be converted to '.'... :wink:
(Ah no, sorry, I think I'm "confusing" you with some other (very Advanced) User with a very similar Username like yours, and who's been around on the Forum since 2008-2009-2010... :P )
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
User avatar
thecoder2012
Posts: 367
Joined: Sat Aug 15, 2015 5:14 pm
Location: Internet
Contact:

Re: Hyphen (-) Not Recognized in PROXY ADDRESS

Post by thecoder2012 » Fri Oct 04, 2019 7:11 pm

chivracq wrote:
Fri Oct 04, 2019 6:59 pm
But OK, was just "an Idea", I don't use Proxies in my Scripts, so I never "really" did any Digging/Testing about it...,
You have too much games with imacros scripts and not enough game accounts at the same time. :wink:
chivracq wrote:
Fri Oct 04, 2019 6:59 pm
@thecoder2012 is much more knowledgeable about that Func than me... :oops:
Good to know. :)
chivracq wrote:
Fri Oct 04, 2019 6:59 pm
And otherwise, @OP, I think you are Advanced enough to modify yourself the '.xpi' to prevent the '-' to be converted to ''.'... :wink:
Yes but not useful. Then script examples for other users are no longer valid. I prefer foxyproxy modification.
Join 9kw.eu Captcha Service now and let your iMacros continue downloads and scripts while you sleep. - Custom iMacros? Contact me! :idea:
chivracq
Posts: 8781
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Hyphen (-) Not Recognized in PROXY ADDRESS

Post by chivracq » Fri Oct 04, 2019 8:02 pm

thecoder2012 wrote:
Fri Oct 04, 2019 7:11 pm
chivracq wrote:
Fri Oct 04, 2019 6:59 pm
But OK, was just "an Idea", I don't use Proxies in my Scripts, so I never "really" did any Digging/Testing about it...,
You have too much games with imacros scripts and not enough game accounts at the same time. :wink:
Oh...!?, "interesting"..., I didn't know you were using iMacros to play Games..., me too, and that's how I discovered iMacros, about 10-12 years ago I think, and where I actually got absolutely all my "Knowledge" about iMacros from...!
"Funny" to see that we are both 2 Advanced Users with iMacros on the Forum and that we both "come from" a "Gaming Context", ah-ah...! :wink:
Seems to be the "best Learning School" to get to use iMacros a bit "up to the Extreme", ah-ah...! :shock:

>>>
thecoder2012 wrote:
Fri Oct 04, 2019 7:11 pm
chivracq wrote:
Fri Oct 04, 2019 6:59 pm
@thecoder2012 is much more knowledgeable about that Func than me... :oops:
Good to know. :)
Yeah well, watch out and "behave", I'm "also" a "Specialist" in "Spanking"...! :twisted: :shock: :twisted:

>>>
thecoder2012 wrote:
Fri Oct 04, 2019 7:11 pm
chivracq wrote:
Fri Oct 04, 2019 6:59 pm
And otherwise, @OP, I think you are Advanced enough to modify yourself the '.xpi' to prevent the '-' to be converted to ''.'... :wink:
Yes but not useful. Then script examples for other users are no longer valid. I prefer foxyproxy modification.
Yeah well, again, just an Idea, if none of your other Workarounds would be working or usable for @OP, and it's a "good Exercise" for experimenting with customizing the Add-on, "this one Case" should be pretty easy... :wink:

I don't see btw how "Then script examples for other users are no longer valid." would have an Impact..., from just preventing a '-' to get automatically and unwantedly converted to some other Char that iMacros apparently incorrectly considers invalid in an URL/Proxy Address... :?
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
User avatar
thecoder2012
Posts: 367
Joined: Sat Aug 15, 2015 5:14 pm
Location: Internet
Contact:

Re: Hyphen (-) Not Recognized in PROXY ADDRESS

Post by thecoder2012 » Fri Oct 04, 2019 9:06 pm

chivracq wrote:
Fri Oct 04, 2019 8:02 pm
"Funny" to see that we are both 2 Advanced Users with iMacros on the Forum and that we both "come from" a "Gaming Context", ah-ah...! :wink:
A little but my games are all gone. I have played with game developers at the end with legal cheats! :D
I have used iMacros only for customers in the last years and since few weeks Kantu.
chivracq wrote:
Fri Oct 04, 2019 8:02 pm
Seems to be the "best Learning School" to get to use iMacros a bit "up to the Extreme", ah-ah...! :shock:
In the past but not in my future. :cry:
Customer wishes are no longer only iMacros.
chivracq wrote:
Fri Oct 04, 2019 8:02 pm
Yeah well, again, just an Idea, if none of your other Workarounds would be working or usable for @OP, and it's a "good Exercise" for experimenting with customizing the Add-on, "this one Case" should be pretty easy... :wink:
And the second case "IDN" in the future? :shock:
chivracq wrote:
Fri Oct 04, 2019 8:02 pm
I don't see btw how "Then script examples for other users are no longer valid." would have an Impact..., from just preventing a '-' to get automatically and unwantedly converted to some other Char that iMacros apparently incorrectly considers invalid in an URL/Proxy Address... :?
You hate copy&paste solutions? :cry:
Join 9kw.eu Captcha Service now and let your iMacros continue downloads and scripts while you sleep. - Custom iMacros? Contact me! :idea:
kkipling5
Posts: 13
Joined: Sat Aug 03, 2019 7:29 am

Re: Hyphen (-) Not Recognized in PROXY ADDRESS

Post by kkipling5 » Fri Oct 04, 2019 9:46 pm

I tried installing the modified FoxyProxy addon that you've posted in a different thread but I was encountering corrupt addon error. I'll play around and see if I can get it to work.

I'll explain the exact use case just in case it is of any help.

Code: Select all

PROXY ADDRESS=zproxy.lum-superproxy.io:22225
ONLOGIN USER=lum-customer-session-rand{{VAR7}} PASSWORD=xyz
While the proxy address and port is supposed to remain same in each loop, I need to add a random variable at the end of username to create a new session. Each new session gets me a new IP and I need one for each loop.

If I manually enter the proxy address and port in Firefox's settings, I'll be presented with the authentication dialogue box just once and hence one IP will stick for all loops.
User avatar
thecoder2012
Posts: 367
Joined: Sat Aug 15, 2015 5:14 pm
Location: Internet
Contact:

Re: Hyphen (-) Not Recognized in PROXY ADDRESS

Post by thecoder2012 » Fri Oct 04, 2019 10:37 pm

kkipling5 wrote:
Fri Oct 04, 2019 9:46 pm
I tried installing the modified FoxyProxy addon that you've posted in a different thread but I was encountering corrupt addon error. I'll play around and see if I can get it to work.
With my xpi file or with your own xpi file (with my instructions)?
Tested only with Waterfox, Pale Moon and Basilisik Browser because your old firefox version has no updates.
Join 9kw.eu Captcha Service now and let your iMacros continue downloads and scripts while you sleep. - Custom iMacros? Contact me! :idea:
kkipling5
Posts: 13
Joined: Sat Aug 03, 2019 7:29 am

Re: Hyphen (-) Not Recognized in PROXY ADDRESS

Post by kkipling5 » Sat Oct 05, 2019 7:49 am

I tried the modified version you had uploaded.
User avatar
thecoder2012
Posts: 367
Joined: Sat Aug 15, 2015 5:14 pm
Location: Internet
Contact:

Re: Hyphen (-) Not Recognized in PROXY ADDRESS

Post by thecoder2012 » Sun Oct 06, 2019 4:13 pm

kkipling5 wrote:
Sat Oct 05, 2019 7:49 am
I tried the modified version you had uploaded.
You have right. I have checked your Firefox Version 49 in my VM with Windows.

Solution for this old version:
1. Create file config.js
2. Insert code into config.js

Code: Select all

//
try {
Components.utils.import("resource://gre/modules/addons/XPIProvider.jsm", {})
.eval("SIGNED_TYPES.clear()");
}
catch(ex) {}
3. Move config.js to application work folder, eg: C:\Program Files\Mozilla Firefox\
4. Create config-prefs.js and write code into:

Code: Select all

pref("general.config.obscure_value", 0);
pref("general.config.filename", "config.js");
5. Place config-pres.js to C:\Program Files\Mozilla Firefox\defaults\pref\
6. Restart Firefox
7. Install your foxyproxy xpi with modification
8. You can remove both files (config.js, config-prefs.js) after your foxyproxy install if this is your wish.

Source https://stackoverflow.com/questions/192 ... 4#56826754 and http://forums.mozillazine.org/viewtopic ... #p14755881
Join 9kw.eu Captcha Service now and let your iMacros continue downloads and scripts while you sleep. - Custom iMacros? Contact me! :idea:
Post Reply