Disable Script Debugging in iMacros Browser

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
whitertlnav
Posts: 43
Joined: Tue Mar 28, 2006 4:10 pm

Disable Script Debugging in iMacros Browser

Post by whitertlnav » Fri Jul 20, 2007 4:14 pm

Please add the ability to disable script debugging in iMacros browser. Additionally, please allow the ability to suppress notifications of scripting errors. Both of these settings can be changed in Internet Explorer's options, but these options do not carry over to iMacros because this has not been implemented in your code. Please implement these features in the next beta release, and you will relieve a major headache.

Thanks
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Mon Jul 30, 2007 2:48 pm

The iMacros browser uses the IE settings. Did you restart the iMacros browser after changing the IE settings?
whitertlnav
Posts: 43
Joined: Tue Mar 28, 2006 4:10 pm

Post by whitertlnav » Mon Jul 30, 2007 7:53 pm

You clearly do not know what you're talking about.

The iMacros browser may be BASED off of the IE settings, but that does not mean that it uses those settings exclusively. When interfacing with the browser control, the developers need to implement specific features in order for them to work properly. This is documented by Microsoft, and it even explains how to do it.

I have restarted the iMacros browser, and I have even disabled script debugging in group policy settings and the registry. Even with these settings, iMacros continues to display script errors. If I go back and check the IE settings, they show that script debugging is disabled (and it can't be changed due to group policy), yet iMacros continues to display script errors in the iMacros browser. And no, using the IE broswer instead of the iMacros browser is not an option.

This is not an isolated instance by the way. Another area where iMacros overrides the user's preference is with the "Close this window when downloads complete" setting within IE. I have this set to keep the window open, but whenever iMacros downloads a file through the iMacros browser, this setting is changed to close the window automatically.

So, before you respond next time, make sure you have your facts straight.
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Fri Aug 10, 2007 1:26 am

Sorry for the confusion. I was using an internal beta version which already includes this feature. Starting with iMacros V6 Beta 4 all run-time script errors are suppressed.

You can disable the javascript debugging notification in your IE settings. It is under tools --> Internet options --> Advanced --> disable script debugging.

All suppressed script errors are logged:

Example:

Code: Select all

8/8/2007  3:12:38 PM  3944  Web Page Script Error: Object expected
agordon10
Posts: 133
Joined: Sun Jun 10, 2007 8:10 pm

Post by agordon10 » Mon Aug 13, 2007 11:01 am

the reason, at least in my case, whitertlnav, that the imacros browser shows these errors and they are not corrected, has nothing to do with the option tech support has offered.
I have the exact same issue and so do many others judging by this forum.
If you run the macro in IE even with the script debugging logging, there is no script error, the script error ONLY occurs in the imaros browser, therefor, disabling script debugging does not solve the problem.
I'm thinking the suppression won;t make a difference because oftem times the imacros browser closes on these script errors.
whitertlnav
Posts: 43
Joined: Tue Mar 28, 2006 4:10 pm

Post by whitertlnav » Mon Aug 13, 2007 10:21 pm

Yeah, it's pretty clear that Tech Support (ironic) doesn't have a handle on the issue. The only way the "Disable Script Debugging" option works in any IE-based web browser control is if this feature has been SPECIFICALLY enabled by the developer. The fact that the errors ONLY appear in the iMacros browser confirms that this feature was not enabled. Here are two links that reference this issue:

http://support.microsoft.com/kb/279535
http://support.microsoft.com/kb/261003/

In addition, a Google search for "webbrowser control disable script debugging" will reveal NUMEROUS other discussions about the same issue in many other programming languages.[/url]
rbowles
Posts: 20
Joined: Wed Mar 21, 2007 7:53 pm

Post by rbowles » Tue Aug 14, 2007 8:51 pm

When will the Beta 4 be released?
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Tue Aug 14, 2007 9:46 pm

Beta 4 was released today. It contains the option to disable script debugging (it uses the IE settings as discussed above).
thepemberton
Posts: 6
Joined: Fri Sep 04, 2009 2:16 am

Re: Disable Script Debugging in iMacros Browser

Post by thepemberton » Fri Sep 04, 2009 2:07 pm

This doesn't seem to work any longer?

I'm using the demo version of iMacros Browser 6.60 build 107
Vista 32bit Home Premium build 6001 Service Pack 1
IE version 8.0.6001.18813

I've verified that in IE, the "Disable Script Debugging (IE)" and "Disable Script Debugging (other)" are CHECKED, and "Display a notification about every script error" is UNCHECKED

I've also verified that in the registry the keys (all REG_SZ) are set properly:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\Disable Script Debugger] = yes
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\DisableScriptDebuggerIE] = yes
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\Disable Script Debugger] = yes
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\DisableScriptDebuggerIE] = yes

Can you provide up-to-date info, or fix this? Or perhaps it's giving these problems because it is the Trial version? Also note that the extracts don't work. The Extract wizard says it's FRAME F=1, but it simply doesn't work!

Example code below:

Code: Select all

VERSION BUILD=6600525     
CLEAR
TAB T=1     
TAB CLOSEALLOTHERS
SET !ERRORIGNORE YES
SET !TIMEOUT 5
URL GOTO=http://www.google.com
WAIT SECONDS=#DOWNLOADCOMPLETE#  
FILTER TYPE=IMAGES STATUS=ON
URL GOTO=http://www.stumbleupon.com/s/#2AwYRS/haha.nu/creative/creative-photos-by-chema-madoz/    
WAIT SECONDS=#DOWNLOADCOMPLETE#
FRAME F=1
TAG POS=1 TYPE=A ATTR=TXT:*&&TITLE:Permanent<SP>Link<SP>to<SP>Creative<SP>photos<SP>by<SP>Chema<SP>Madoz&&HREF:http://haha.nu/arts/photography/creative-photos-by-chema-madoz/ EXTRACT=HREF  
TAG POS=1 TYPE=LI ATTR=CLASS:commentbody&&TXT:*&&ID:comment-17825 EXTRACT=TXT  
thepemberton
Posts: 6
Joined: Fri Sep 04, 2009 2:16 am

Re: Disable Script Debugging in iMacros Browser

Post by thepemberton » Fri Sep 04, 2009 2:18 pm

Edit: This only works part of the time. Lowering the timeout (to simulate a slow connection) results in the same errors mentioned above.

Ok, I think I've managed to work around this by reversing the order of lines 14 and 15. Near the bottom I changed this:

Code: Select all

WAIT SECONDS=#DOWNLOADCOMPLETE#
FRAME F=1
to this:

Code: Select all

FRAME F=1
WAIT SECONDS=#DOWNLOADCOMPLETE#
And it seems to work! I didn't know #DOWNLOADCOMPLETE# was frame-specific! Can you note this in the Wiki?
Edit: This only works part of the time. Lowering the timeout (to simulate a slow connection) results in the same errors mentioned above.
marzah
Posts: 3
Joined: Fri Feb 20, 2009 5:38 am

Re: Disable Script Debugging in iMacros Browser

Post by marzah » Sat Nov 07, 2009 6:26 pm

I just renewed my subscription and upgrade to v6.8
I am using Windows XP clean install with Explorer 8.
When running scripts in the Imacros Browser I have the same problem I get script debuggin erros regardless of what settings I put. Just like the previous poster I have double checked all of my settings and they are correct
Will this be fixed
huyrich
Posts: 3
Joined: Tue Dec 01, 2009 2:09 am

Re: Disable Script Debugging in iMacros Browser

Post by huyrich » Sun Oct 31, 2010 1:04 am

After 3-4 years, it still does not support "Disable Script Debugging" in version 6.9.
I bet "Tech Support" and "Developers" have no clue. What a joke!
cheppynov
Posts: 4
Joined: Fri Dec 10, 2010 10:35 am

Re: Disable Script Debugging in iMacros Browser

Post by cheppynov » Fri Dec 10, 2010 10:37 am

Is this issue alredy fixed?
Chase1109
Posts: 1
Joined: Wed Aug 11, 2010 3:54 pm

Re: Disable Script Debugging in iMacros Browser

Post by Chase1109 » Wed Jun 15, 2011 3:35 pm

I think it'd be fair enough to note that using ONERRORDIALOG does not resolve this issue either.
Post Reply