iMacros stops working in FF43

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
St0n3
Posts: 1
Joined: Wed Dec 23, 2015 2:42 pm

iMacros stops working in FF43

Post by St0n3 » Wed Dec 23, 2015 4:38 pm

Hello,
I have a problem with iMacros and Firefox and I have the same problem no matter which versions I'm using.

First of all I what tell you, that I have searched the forum and that I have read the other threads about the not responding imacros, but that's not the same problem.
I have another problem.

I tried:
Firefox (Portable) v36 with iMacros v8.9.4
then I've upgraded my Firefox and tried:
Firefox (Portable) v43.0.2 with iMacros v8.9.4
Firefox (Portable) v43.0.2 with iMacros v8.8.5.1
Firefox (Portable) v43.0.2 with iMacros v8.8.7.1

My OS is Windows 7 Ultimate x64

But the problem is always the same.
I have a problem with some scripts. Each of them contains of 1 *.js file and several *.iim files. After starting the script, it should run an infinite loop.
If I run the *.js my script starts to run but after a while it stops working. It don't stop always at the same point or after the same time, it is random when the script will stop.
Sometimes it runs only a few lines and sometimes it works well for 1 loop.

If it stops, I see something like this:
Image

Even if after the macro timeout which I had specified in the javascript file, the script didn't continued.

After the script has stopped working, I can only click the stop button. And if I do this, I will see the code of the javascript file:
Image

Then I can't to anything anymore.
If I want to restart the loop, I have to open a new firefox window.

Anyone has an idea?

Thanks.

St0n3
User avatar
Edoctoor
Posts: 34
Joined: Sun Nov 29, 2015 7:53 pm

Re: iMacros stops working in FF43

Post by Edoctoor » Fri Dec 25, 2015 10:48 am

I have an idea... let us see the script... ;-) you can compress them as a zip file... or post and select the macro and click "CODE"... but most importantly... tell us what Operating system, your version of Imacros your finally settling on, and what browsers that it will be running on... otherwise.. there really is no way that we could guess what is happening... best regards.
iMacros Version 11.0.246.4051
Browser FireFox 42.0
OS Windows 7 Home Premium - Service Pack 1

Before starting a topic please read the following; thank you!
http://forum.imacros.net/viewtopic.php?f=20&t=3331#p8799
Post Reply