iMacro clears entered data

Discussions and Tech Support specific to the iMacros Firefox add-on.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
vkladchik
Posts: 1
Joined: Fri Jun 08, 2007 7:45 pm

iMacro clears entered data

Post by vkladchik » Fri Jun 08, 2007 7:54 pm

I'm trying to automate clicking through a few pages after entering a certain value in a page.

http://www.wipo.int/ipdl/en/

In the first page, I enter the number of a patent, say for example, jp2005001825, select PCT (patents), and click search.

That will take me to a page with a hyperlinked title of a patent.

Clicking that takes me to the bibliographic information page for that patent. On this page I click "Documents" (far right tab under the title).

This takes me to a page with various documents related to that patent, and the one I need is the PDF (orange button, second from right), for the document which is always at the bottom of the list. In this example there's only one document available (Initial Publication with ISR (A1 33/2006)), but sometimes there are more. I only ever need the PDF for the last document.

This opens a new window that loads the pdf.

I want to enter the patent number on the first page, click "run" on the macro, and have the pdf pop up, without having to click through the same pages and buttons every time.

Unfortunately, when I try using the Firefox iMacro add-on for this, the first thing it does is clear the patent number I entered, and undo the "PCT (Patents)" selection, so it doesn't work.

Does anyone have any advice? I've tried the various link selection options (URL name, HTML, X/Y, etc.) but none work.

Thanks,
Marc
User avatar
Tech Support
Posts: 4947
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Wed Jun 13, 2007 8:37 pm

After you record the macro, you must manually remove the URL GOTO statement at the beginning of the macro.

The reason for this is: URL GOTO... (re-)loads the page, thus the patent number is cleared. Without URL GOTO... iMacros starts working on the page directly.
Post Reply