Simple problem TAG POS=1

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
billw
Posts: 4
Joined: Sat Jun 06, 2015 8:11 pm

Simple problem TAG POS=1

Post by billw » Sat Jun 06, 2015 8:18 pm

Hi, recently I started using imacros,
I have simple problem if you can help

I need imacros to follow a link,
it is
TAG POS=1
or
TAG POS=2
Regardless is it POS=1 or POS=2 I need imacros to click on that link.

I tried some other solutions that I find or other threads, but didnt find.
I would like to avoid using "SET !ERRORIGNORE YES".
If you can help because I am not skilled with coding.
chivracq
Posts: 9507
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Simple problem TAG POS=1

Post by chivracq » Sun Jun 07, 2015 5:53 am

billw wrote:Hi, recently I started using imacros,
I have simple problem if you can help

I need imacros to follow a link,
it is
TAG POS=1
or
TAG POS=2
Regardless is it POS=1 or POS=2 I need imacros to click on that link.

I tried some other solutions that I find or other threads, but didnt find.
I would like to avoid using "SET !ERRORIGNORE YES".
If you can help because I am not skilled with coding.
CIM...! :mrgreen: (I don't read...)

And pfff, try searching the Forum with "Simple problem TAG POS=1" to find a Solution for your Pb... Your Thread Title is a bit completely useless... Find stg better for other Users in the Future with the same Pb... (And sorry your Thread Title is so useless that I didn't even read the Content...)
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
billw
Posts: 4
Joined: Sat Jun 06, 2015 8:11 pm

Re: Simple problem TAG POS=1

Post by billw » Sun Jun 07, 2015 9:59 am

It is very stupid to comment if you "didn't read", also to quote a text which is right above your comment is unnecessary. :lol:
chivracq
Posts: 9507
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Simple problem TAG POS=1

Post by chivracq » Mon Jun 08, 2015 1:47 am

billw wrote:It is very stupid to comment if you "didn't read", also to quote a text which is right above your comment is unnecessary. :lol:
Yep I know I can act/react very stupid(ly) but I usually adapt my Reaction to the Level of the Person asking... So impress me a little bit(*)... :idea:
I guess you came to this Forum with a Pb..., and I'm usually your best Friend, Mister/Mistress_Stranger_who_behaves_like_he/she's_the King/Queen_of_the iMacros_World_with_a_Problem_with_iMacros, if you do things a bit correctly...

(*) But I think you've already passed Level 2 of Stupidity, by reading your first Reaction...
Wondering if you really have a Pb/Question related to iMacros or if you are just looking for interesting Forums where you can act a bit as a Troll...!? :roll:
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
billw
Posts: 4
Joined: Sat Jun 06, 2015 8:11 pm

Re: Simple problem TAG POS=1

Post by billw » Tue Jun 09, 2015 9:30 am

Apart of being stupid, you are illiterate, you don't understand usage of capital letter, I guess you don’t have schools in Netherlands.
I can see you are one frustrated and sad individual, without real life. I feel sorry for you.
chivracq
Posts: 9507
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Simple problem TAG POS=1

Post by chivracq » Tue Jun 09, 2015 10:26 am

billw wrote:Apart of being stupid, you are illiterate, you don't understand usage of capital letter, I guess you don’t have schools in Netherlands.
I can see you are one frustrated and sad individual, without real life. I feel sorry for you.
Yep, sure... :roll:
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
billw
Posts: 4
Joined: Sat Jun 06, 2015 8:11 pm

Re: Simple problem TAG POS=1

Post by billw » Tue Jun 09, 2015 11:55 am

Anyway, I find solution to my problem :D (as I explained it), if anyone else experience the same problem, here is the answer:
http://stackoverflow.com/questions/5634 ... other-href

SET !VAR1 {{!LOOP}}
ADD !VAR1 {{!LOOP}}
'now !var1 = 2*!loop. Subtract 1 to get odd numbers.
ADD !VAR1 -1

This was all the code I needed. I like imacros, because even if I am not a coder I can find it very useful. :D
Thanks to people of good will on that page who like to help!
ZmanZoo
Posts: 21
Joined: Mon Feb 16, 2015 8:24 pm

Re: Simple problem TAG POS=1

Post by ZmanZoo » Thu Jun 11, 2015 5:59 pm

Glad you found the answer, and yes there are people on this site that do try to help. and Thanks for posting the solution (actually helped with something I've been tinkering around with)

until next time.
Post Reply