Turn Off Compatibility View in the component

Discussions and Tech Support related to using the iMacros Component for .NET in your applications.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
rguez_18
Posts: 102
Joined: Thu Oct 20, 2005 6:04 pm
Contact:

Turn Off Compatibility View in the component

Post by rguez_18 » Wed Sep 19, 2012 10:02 pm

Hi,
Is there a way to turn-off the compatibility view when running scripts from the component? I have a script that does G+ clicks and doesnt work when running on the component. below is my script. This works fine running on the regular imacro browser. Thanks!

VERSION BUILD=7511734
TAB T=1
SET !TIMEOUT_STEP 3
TAB CLOSEALLOTHERS
URL GOTO=https://accounts.google.com/ServiceLogi ... src*&hl=en
SET !ERRORIGNORE YES
TAG POS=1 TYPE=A ATTR=ID:link-force-reauth
SET !ENCRYPTION NO
SET !ERRORIGNORE NO
TAG POS=1 TYPE=INPUT:TEXT FORM=ID:*_loginform ATTR=ID:Email CONTENT={{USERNAME}}
TAG POS=1 TYPE=INPUT:PASSWORD FORM=ID:*_loginform ATTR=ID:Passwd CONTENT={{PASSWORD}}
TAG POS=1 TYPE=INPUT:CHECKBOX FORM=ID:*_loginform ATTR=ID:PersistentCookie&&VALUE:yes CONTENT=NO
TAG POS=1 TYPE=INPUT:SUBMIT FORM=ID:*_loginform ATTR=ID:signIn&&VALUE:Sign<SP>in
WAIT SECONDS=5
TAG POS=1 TYPE=SPAN FORM=ID:gaia_loginform ATTR=ID:errormsg_*_Passwd CONTENT=EVENT:FAIL_IF_FOUND
SET !ERRORIGNORE YES
URL GOTO=http://courtreporteru.com/
WAIT SECONDS=5
FRAME F=1
TAG POS=1 TYPE=SPAN ATTR=ID:button&&CLASS:hAa<SP>Qo<SP>Bg&&ROLE:button
.NET Developer
<---Using IMacro since version 4 - See Date Joined on Forum
***For Quotes and Estimates please feel free to contact me.
YM: Rguez_18 <at> y a hoo <that> com
Skype: Rguez_18
Tom, Tech Support
Posts: 3482
Joined: Mon May 31, 2010 4:59 pm

Re: Turn Off Compatibility View in the component

Post by Tom, Tech Support » Thu Sep 20, 2012 12:25 pm

Hi Ryan,

Have you already taken into account item #3 in the following section (also included with the component Readme file)?

http://wiki.imacros.net/Component#What_ ... hould_know
Regards,

Tom, iMacros Support
rguez_18
Posts: 102
Joined: Thu Oct 20, 2005 6:04 pm
Contact:

Re: Turn Off Compatibility View in the component

Post by rguez_18 » Thu Sep 20, 2012 12:28 pm

Awesome! Thanks for the prompt reply, I'll try it out and let you know the results! Cheers!
.NET Developer
<---Using IMacro since version 4 - See Date Joined on Forum
***For Quotes and Estimates please feel free to contact me.
YM: Rguez_18 <at> y a hoo <that> com
Skype: Rguez_18
rguez_18
Posts: 102
Joined: Thu Oct 20, 2005 6:04 pm
Contact:

Re: Turn Off Compatibility View in the component

Post by rguez_18 » Thu Sep 20, 2012 8:59 pm

Hi Tom,
The settings didn't really worked for me, I added my application name on the registry key mentioned but still have the same issue (SEE IMAGE 1)
IMAGE 1:
Image

Here's a screenshot of what happens when I log into google+ using the .NET component
IMAGE 2:
Image

The issue is that the google+ button event is not being triggered when the message above is encountered but shows the button with blue margin which means the script is able to find the button.
Image

Thanks so much in advance for your help. Cheers!
.NET Developer
<---Using IMacro since version 4 - See Date Joined on Forum
***For Quotes and Estimates please feel free to contact me.
YM: Rguez_18 <at> y a hoo <that> com
Skype: Rguez_18
Tom, Tech Support
Posts: 3482
Joined: Mon May 31, 2010 4:59 pm

Re: Turn Off Compatibility View in the component

Post by Tom, Tech Support » Tue Sep 25, 2012 2:23 pm

Hi Ryan,

There were no images linked to your last post.
Regards,

Tom, iMacros Support
Post Reply