Loop is not incremeting

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
stvinatl
Posts: 1
Joined: Wed Sep 19, 2007 1:17 am
Location: United States

Loop is not incremeting

Post by stvinatl » Wed Sep 19, 2007 1:23 am

Hi there, umm- i have a csv file of data that i need to read from and post values to a website- the behavior that i am seeing is this-

it reads the 1st line from the csv file correctly and posts properly- afterwards it seems to try to goto the 2nd loop but does not read any of the values from the CSV file-

i copied my script from the CSV loop example, my code is below

thanks a million!

Code: Select all

VERSION BUILD=3700331  
VERSION BUILD=6000818 RECORDER=FX     
'Uses a Windows script to submit several datasets to a website, e. g. for filling an online database
TAB T=1     
TAB CLOSEALLOTHERS  
URL GOTO=https://na2.salesforce.com/home/home.jsp
' Specify input file (if !COL variables are used, IIM automatically assume a CSV format of the input file
'CSV = Comma Separated Values in each line of the file
CMDLINE !DATASOURCE 807lead.csv
'Number of columns in the CSV file. This must be accurate!
SET !DATASOURCE_COLUMNS 6
'Start at line 2 to skip the header in the file
SET !LOOP 1
'Increase the current position in the file with each loop 
SET !DATASOURCE_LINE {{!LOOP}}
' Fill web form   
URL GOTO=https://na2.salesforce.com/home/home.jsp     

TAG POS=1 TYPE=DIV ATTR=ID:createNewButton&&TXT:Create<SP>New...
TAG POS=1 TYPE=A ATTR=TXT:Account
TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:editPage ATTR=ID:acc2 CONTENT={{!COL1}}
TAG POS=1 TYPE=SELECT FORM=NAME:editPage ATTR=ID:00N30000000geOg CONTENT=$Target
TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:editPage ATTR=ID:acc10 CONTENT={{!COL6}}
TAG POS=1 TYPE=TEXTAREA FORM=NAME:editPage ATTR=ID:acc17street CONTENT={{!COL2}}
TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:editPage ATTR=ID:acc17city CONTENT={{!COL3}}
TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:editPage ATTR=ID:acc17state CONTENT={{!COL4}}
TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:editPage ATTR=ID:acc17zip CONTENT={{!COL5}}
TAG POS=1 TYPE=A ATTR=TXT:Copy<SP>Billing<SP>Address<SP>to<SP>Shipping<SP>Address
TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:editPage ATTR=ID:acc23 CONTENT={{!COL2}}
TAG POS=2 TYPE=INPUT:SUBMIT FORM=NAME:editPage ATTR=NAME:save&&VALUE:<SP>Save<SP>
TAG POS=1 TYPE=INPUT:BUTTON FORM=NAME:NoFormName ATTR=NAME:new&&VALUE:Log<SP>A<SP>Call
TAG POS=1 TYPE=TEXTAREA FORM=NAME:editPage ATTR=ID:tsk6 CONTENT=sent<SP>info
TAG POS=1 TYPE=INPUT:SUBMIT FORM=NAME:editPage ATTR=NAME:save&&VALUE:<SP>Save<SP>
my2testing
Posts: 21
Joined: Tue Oct 30, 2007 6:57 am
Contact:

Post by my2testing » Wed Jan 09, 2008 9:57 am

Code: Select all

SET !DATASOURCE_LINE 1 
Post Reply