Object Reference Error on 64 bit machine

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.
Post Reply
shaves
Posts: 64
Joined: Tue Apr 29, 2008 6:50 pm

Object Reference Error on 64 bit machine

Post by shaves » Fri Jul 07, 2017 3:06 pm

I have a macro that has been working great on 32 bit machines with iMacros version 10.3. I've trying to update it to run on a 64 bit machine with iMacros version 11.0

The macro is already in the PeopleSoft Financials application and is trying to navigate to a query screen with the following code:

IM = ""
IM = "CODE:"
IM = IM + "TAB T=1" + vbNewLine
IM = IM + "TAB CLOSEALLOTHERS" + vbNewLine
IM = IM + "SET !PLAYBACKDELAY 0.2" + vbNewLine
IM = IM + "URL GOTO=https://pswebfsprd.corp.erac.com/psc/fs ... IC.ZAPQ044" + vbNewLine

When the above code executes, iMacros displays the following error:

Error -1000: Object reference not set to an instance of an object.. Line 4: URL GOTO=https://pssprd.corp.com/psc/fsprd_1/EMP ... IC.ZAPQ004

Machine: 64 bit
Operating System: Windows 7 Enterprise
iMacros: 11.0.246.4051

Any suggestions would be greatly appreciated. Thanks for the help.........
chivracq
Posts: 8034
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Object Reference Error on 64 bit machine

Post by chivracq » Fri Jul 07, 2017 3:21 pm

shaves wrote:I have a macro that has been working great on 32 bit machines with iMacros version 10.3. I've trying to update it to run on a 64 bit machine with iMacros version 11.0

The macro is already in the PeopleSoft Financials application and is trying to navigate to a query screen with the following code:

Code: Select all

IM = ""
IM = "CODE:"
IM = IM + "TAB T=1" + vbNewLine
IM = IM + "TAB CLOSEALLOTHERS" + vbNewLine
IM = IM + "SET !PLAYBACKDELAY 0.2" + vbNewLine
IM = IM + "URL GOTO=https://pswebfsprd.corp.erac.com/psc/fsprd_1/EMPLOYEE/ERP/q/?ICAction=ICQryNameURL=PUBLIC.ZAPQ044" + vbNewLine
When the above code executes, iMacros displays the following error:

Code: Select all

Error -1000: Object reference not set to an instance of an object.. Line 4: URL GOTO=https://pssprd.corp.com/psc/fsprd_1/EMPLOYEE/ERP/q/?ICAction=ICQryNameURL=PUBLIC.ZAPQ004

Code: Select all

Machine:    64 bit
Operating System:  Windows 7 Enterprise
iMacros:  11.0.246.4051
Any suggestions would be greatly appreciated. Thanks for the help.........
Hum, no idea actually as I've never used iMB nor the Scripting Interface, but hum..., I notice that the URL is a bit different between your Script and the RuntimeError:

Code: Select all

https://pswebfsprd.corp.erac.com
https://pssprd.corp.com
You could try using the URL from the Error Msg directly in your Script...
And you could try using '!ERRORIGNORE' if the Page actually loads correctly...
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
Post Reply